Solid Purple LED

every time I power my Core it flashes
breathing cyan
then stops on solid purple.
any one got any ideas or help ?

In cases like this - especially without enough insight into your running firmware - the way to get out of this will be a factory reset.

Thanks scruffR,
I think it’s still got the firmware that it came with backs when I got it (kickstarter pledge) I haven’t had a chance to play with it for a fair few months

Sounds like it’s time to upgrade everything to a stable version! :smile:

Have you installed particle-cli (spark-cli) before?

1 Like


Try installing it with the instructions here:



and we can continue from there: )

1 Like

Same problem here. Does the CLI work on Linux (Ubuntu 14.04LTS) too?

Yes it should work fine (except for sudo for USB features maybe) :smile:

Got it working - some commands require sudo (until I figured out the right rights settings). Now where do I get the current firmware for the core?

how did you get the dfu-util to work ?
ive added the usb_drive folder to the cmd promt,
I can see all the files located inside
but nothing happens when I try dfu-util -1

I downloaded this file:

Then I tried:
sudo particle flash --usb core-firmware.bin

But got the error:
checking file core-firmware.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D core-firmware.bin
invalid dfuse address: 0x08005000:leave
Error writing firmware…

Core happily blinking yellow.

When I tried: sudo dfu-util -l

I get (which looks OK to me):
dfu-util 0.5

© 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
© 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,108001Kg"
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg"

I used sudo dfu-util -l (that’s lowercase L, not number one)

im still stuck trying to find “dfu-util.exe” here’s a screen shot of the files I’ve download

Doesn’t the installer contain it?

I have run the dfu-util.exe It just flashes a command prompt window up very quickly then closes. and I cant run the duf-utl.tar.xz file

Did you start it from the command line? You need to provide all the parameters. If you run it from Explorer probably nothing happens

if I try the 64bit installer it says use the initial installer application
if I try the dfu-uitl-0.8-binaries.taz.xz is says its not recognized as an internal or external command.

I don’t know what I am doing wrong but nothing seems to be working


you need to use it like dfu-util -l. This will list the DFU devices detected

1 Like