SmartConfig Not Working on iOS 7.1?!

Has anyone tried SmartConfig in the Tinker app since updating to iOS 7.1? Since updating last night, SmartConfig flat out does not work on any of my Cores. I’ve tried: Upgrading the factory reset firmware to v2, restarting the phone, restarting the router, different power supplies, taking the core out of the breadboard, placing it and the phone within 10 feet (line of sight) to the router, different networks, different brand routers, unsecured networks, secured networks and nothing works. The only thing that’s changed since I last did a SmartConfig is upgrading to iOS 7.1!

Anyone else having issue? :frowning:

Nope, but then again I’m running iOS 7.0.4.

Try updating and see if it stops working?

That’s not very enticing. =P

1 Like

2 Likes

I’m going to try it as soon as my phone finishes its update. Is the code for the iOS mobile app published somewhere?

Interesting… If I use TI’s SmartConfig iPhone App, it works fine! (Using AES Key sparkdevices2013).

So! It’s safe to update to iOS 7.1, as TI’s app works, so at the very least you won’t be forced to tether the Core and configure it over USB if the Spark App is running into issues with the new iOS update.

@Ric The Android version is published, but not the iOS version yet. The team has given me access for a project I’m working on, so I could take a look.

3 Likes

1 Like

I tried it with iOS 7.1, and it didn’t work for me either. Unfortunately, neither did the TI app. Do you need to change the name of the device (from CC3000) in addition to using sparkdevices2013 as the key?

No, but once you enter the key in the TI app, make sure you tap the little circle/checkbox that’s to the right of the box. This enables/disables sending the key. It’s stupid, I know.

Thanks, that worked but it took a lot longer then the Tinker app. Do you know if the code for the iOS mobile app is published?

I’m on iOS7.1 but smart config never works for me, so I don’t think me checking will help. I’ve only ever been able to set WiFi using USB. Gave up on the smart config thing. :frowning:

Hmm, Just tested this on iOS 7.1 on my iPhone 4s, and smart config worked, but I’m connected to a 802.11g only network. I wonder if 7.1 tries harder to do 802.11n / ac?

Hmmm, then why would the TI app work?

Weird. After using the TI app, the Spark app is working. Very strange! @Ric Try the Spark app again!

I tried again several times this morning, and I still can’t connect using the Spark app – eventually, it times out, and I get a message, “no cores found”. When I tried the TI app after trying the Spark one, it also doesn’t work until I do another reset of the core. After doing that, it (the TI app) connected in about 10 seconds.

Ok, I tried again. This time after the factory reset, I tried the TI app first, and it worked. I did another reset, and now the Spark app also worked, connecting in about 5 seconds. Weird.

1 Like

I had similar problems, I think I figured out the problem:
I have an iPhone 5 and my WiFi router has both 5Ghz and 2.4Ghz networks with the same name (AirPort router), when I tried to setup the core relatively near to the router it didn’t work, when I tried on the next room minutes later it worked. It appears that the problem was that the iPhone was communicating with the network on the 5Ghz frequency. This did not happen when I was setting the core up with an iPhone 4s… so I assume that that was the problem.

Probably an enhancement on the iPhone5 together with the firmware causing the issue of choosing a better Ghz :slight_smile:

1 Like