My iPhone's Spark App can't find and connect my core

My Spark board connected my office Wifi and is working with Spark Build page well.
I uploaded my new code through the build web page, it is working well.
It seems that my board is connected WIFI and Cloud now.
But I couldn’t connect my board with my iPhone App, I followed all instructions on Spark web page.

My iPone is iPhone4.

Anybody has same issue as me?

What kind of code did you upload, and what app are you using (the standard Tinker app?)

I uploaded the example code “BLINK AN LED” for testing. It is working well.
Yes, I am using Tinker App.

What exactly did you hope to achieve by using the app on the “blink an LED” sketch?

The problem lies in the fact that your Tinker app just sends out some commands through the REST API. These commands need to be taken care of on the Core. In the factory the Cores are flashes with a Tinker sketch, the same that is being restored when you perform a factory reset. This sketch has the required code to deal with the commands being send by the app.
When you flash your own sketch, you override the factory Tinker sketch, and therefor the code that deals with the app commands. This is why your Core will not respond to any actions you perform in the app, from the moment you overwrite it with your own sketch. You could however add the required code to your own sketch to deal with the commands sent from the app.
The Tinker sketch can be found here. You should be able to extract the necessary code from it and add it to your own sketch.
This might be a very interesting alternative as well, it works great, and is a fantastic starting point!

This thread might prove useful, practically the same discussion:

@Dave (or any of the :spark: guys for that matter), it might be useful to mention the above somewhere in the documentation, or in the description of the app. It seems as if there’s been quite some confusion lately around the Tinker app versus Tinker software. Some explanation of the two might save a few headaches :wink:

1 Like

Hi @pwoong,

The tinker mobile app only works with the tinker firmware.

You can reflash the firmware using the option in the menu on your phone if you want to use it. :slight_smile:

If you want to use your own firmware and at the same time control using your mobile, the Android app source code is available or there’s web app examples too.

1 Like

Thank you guys for replying my issue.
I think my issue is very basic, it didn’t work “Smart config with the Spark App”.
I connected my board with Wifi through the connect over USB, not smart config.
Before testing Tinker App, I need to connect wifi through the Spark App, right?
But I couldn’t connect wifi with the Spark App. I read all instruction and tried, it didn’t work. Only way to access wifi through the connect over USB and manual set up SSID and pasword, not smart config.
I tried “Smart config with the TI App”, it didn’t work.
I want to conncet my board with my iPhone.

As long as your core is breathing cyan,

You can use your iphone and reflash the tinker firmware.

I’m out right now traveling so I’ll post the screenshots later. Mine is Android though.

Someone with iPhone contribute maybe? :slight_smile:

Basically, power on your core, open the Tinker mobile app, look in the menu for reflash tinker firmware

EDIT:

  1. Make sure your :spark: core is breathing cyan

**Make sure both your mobile and core are on the same Wifi

  1. Use your Tinker app and do the following:

Select the core

Reflash

1 Like

Thank you guys. Finally working my board with my iPhone.

THANK YOU!!!

3 Likes