Cannot get SmartConfig to work with iPhone on IOS 7.1.2

Hi All,

Here’s the deal. 6months ago I was able to configure using Smart Config using my then shiny iPhone 5C. Now I cannot get a new set of credentials to associate the Spark with my router using the same iPhone but uPdated to 7.1.2

Here is my setup.
Router Cisco Linksys WRTG54G ie no 802.11N.
No luck with setting the router in “B” or “G” protocols.
Using Channel 10.

Did several factory resets and clearing of old WiFi networks.

I can configure okay with the USB port but cannot get the iPhone to configure. Presently have four spark cores all paired up.

Looked around the community and I seem to have found all the usual suspects. Have not tried an Android that will be next.

One more thing, I downloaded the Ti-Smart Config App and set the key “sparkdevices2013” and got the red check on the key. Made sure the router was in “B” or “G” modes.

Still no breathing Cyan. Suggestion comments are welcome.


Hey @chipmonk,

I know what you mean, I’m using TP-Link TLWR841N and I can able to send FIRST_TIME_CONFIG just from my phone galaxy S2. I tried to do it with the TI SMART CONFIG android application and sometimes it’s working sometimes not.
When I tried to do the FIRST_TIME_CONFIG with Nexus 5 or Galaxy S3, it’s always failed (also from the Spark application).
I post in the forum and I got an answer from Zachary about the parameter you must write in the TI APP. Try to read the post, maybe it will help you…

In addition, if you do the FIRST_TIME_CONFIG with the TI you won’t get any “handshake” it will be stuck on the “sending” page and maybe your core will be stuck on blinking green.

Good luck,

1 Like


I have good news here (or at least some progress).

I used to do my tests with a Htc One and a regular PC with the Java TI application => no results.
I made the test with a Samsung tablet and got to the blinking green stage.

It’s absolutely normal that the handshake isn’t complete using the TI software with Spark Core as the protocol used by SparkCore is more elaborated (use other network frame for the claiming…)

So I made a step but it’s really bothering me as it means the TI app hos not a deterministic behaviour on different devices. The problem wasn’t on the SparkCore at all.



1 Like


I’m not an expert but I think the problem is with few phones or ‘n’ type wifi network.
I got my new OnePlus One and I can’t complete the first time SmartConfig with it. When I do the SmartConfig with my old Samsung galaxy s2 everything going well.

For the handshake, if the phone will success to send the first time SmartConfig it will always be stuck at the blinking green because the loop with the smartphone application wasn’t completed.