SIM Datalimits Not Working as Advertised


@will @jeiden @Dave

I have a Particle Electron SIM card that I set the Datalimit to 20MB and just raised it to 50MB.

Particle sends an email saying I will receive an email when the data usage reaches 90% of the 20MB set limit but that never happened. I’ve never received one of these 90% data usage emails in the past either.

Particle also says the SIM card will stop working an hour or so after I cross the 20MB threshold which also didn’t happen this time or the other time before I raised the limit to 20MB.

Why can’t these limits be relied upon as advertised? This has never worked correctly from my experience.


Let me ping someone that might be able to help, @rickkas7 or @ParticleD are you able to assist?


Hey, @RWB.

Thanks for letting us know. We’ll look into it. I know it’s generally working, but we’ll see what the issue might be in your case.

Just FYI, aside from your experience of never getting an email (which sounds like a bug to me) the reason why limits and auto-pausing might not be as reliable as you’d like has to do with the lag in the system.

When your SIM connects and consumes data, each MNO (Mobile Network Operator) keeps track of that and syncs data about when, how long, and how much data your SIM has consumed back to our partner. Each MNO syncs data back using different criteria and timing. Some are very quick (a few minutes) and some are very slow (many minutes). Some wait for a session to close (the Electron to go offline) and some do it periodically (like every few minutes). Also sometimes due to carrier maintenance or other issues, it can be several hours before we get the usage metadata. We fetch the data from our partner as fast as they’ll let us do it and then compare the usage of each SIM to the limits you’ve set.

So there’s natural lag in the system, and if you’re using data really quickly, you could easily go over the limits w/o the Particle limit checking system knowing about it.

I don’t think that’s necessarily your issue, and I don’t know that it completely answers your question. Your question wasn’t about lag, but about not getting the emails and the limits not getting enforced. I just wanted to make you (and anyone else who reads the thread) a little bit of context.

Aside from the above FYI, we’ll look into your issue and get back to you. You gave us the ICCID which is enough for us to start digging. It may be worth emailing support also to make sure the ticket gets into their pipeline.




Correct, the data usage gets updated just fine and frequently before and after I go over the data limits.

I just receive no over limit warnings and the SIM usage never gets blocked automatically. It has always been this way for me, I just never worried or cared enough about it to ask about it until I saw a recent project going a couple MB above the default 5MB limit.

Thanks for looking into this for me and other users.


Investigation will be ongoing.

I’ll be investigating the email delivery issue avenue and I’ll let you know when I have additional information.