Paused SIM - Data limit reached

electron
boron
Tags: #<Tag:0x00007f1ca160d028> #<Tag:0x00007f1ca160cec0>

#1

I have a Boron that I have a 10MB limit set. I got a notification that my 10MB limit has been reached and paused. According to the console it shows Since Jan. 13th the usage is 5.28MB. Is the console delayed in reporting the correct usage or is something wrong here?


Developer Support Update | Boron Pausing and Setup Concerns
#2

In the last few days I also had multiple sims paused early. It could be the rate at which it was using data like a OTA firmware.


#3

Hi TIm,

We’re currently investigating some concerns with our billing API. I suspect that this may be related. As we have more information, we will be sure to update everyone.

I do apologize for any confusion or inconvenience. As necessary, please feel free to file a support ticket


#4

I figured there was something going on… No worries (at least for me right now). Thanks for responding so quickly.


#5

Awhile ago the SIM Data Limits were never actually enforced and I was never notified after going over my set limits.

I’m not sure if that was fixed or not but if you do see the limits working after Partcles API Billing issue is fixed please do post an update here for confirmation the data limits are working.


#6

Hey RWB,

This is actually a separate issue we are currently working with our MVNO on. For our Electron and E Series 2G/3G line of products, MVNO reporting is fairly reliable. But for some of our LTE line of devices, MVNO reporting of data usage is delayed. For customers that have lower limits and high usage, it may not report in a timely manner that they’ve gone over, so we aren’t able to enforce the limit in a timely manner–and as such, end up cutting customers off far past their limit.


#7

In my case my Boron LTE SIM got paused at 2.4MB for a 5MB limit. What I found worse is that the “UNPAUSE” button completely obscures the graph that shows the usage, so no way to tell when it shot up.
Does the Boron have to be online to unpause? The unpausing seems to be failing or timing out and my Boron is turned off right now…


#8

I had an Electron unit paused today due to going over it’s 5 megabyte limit - the day before the billing cycle ended. It got to 5.03 then was paused. I’m not sure why my usage has gone up, it’s been on the same firmware for the past year, with no overages, typically using 2 out of 3 megabytes.

I unpaused it this morning to keep it going, but it has not yet come back to life. I’ve opened a ticket to see if anything can be done to make it restart, it wakes every 10 minutes to send sensor data, so has woken and tried to connect about 40 times since I sent the unpause request.

I do remember once before (18 months ago) having a problem restarting a paused unit, eventually it seemed to restart on it’s own, but it was after a significant delay, a week or two. These units are very remote, so fingers crossed it comes back to life without onsite intervention.


#9

Thanks for the feedback.

Let us know how long it takes to reconnect.


#10

Hey Tve,

The Boron does not need to be online to be unpaused.

There are some complications with our LTE devices handled with our partner MVNO that can cause some obstruction in data reporting or timely pausing/unpausing. I suspect this is likely the issues you were seeing. I know that a lot of these issues are being investigated (including the premature pausing) right now and I hope to have some more information sooner rather than later for everyone.


#11

Mine would not unpause while offline. It supposedly hit the 5MB limit again but only showed 3MB usage.

If there is a way to add in a reporting feature to get an email with a daily usage report that would be great. Just a future feature request…

Thanks!


#12

I have an E-Series LTE device that cannot be unpaused as well. Same symptoms that others describe.

I’ve also had exactly the same experience on a separate occasion with a different E-Series LTE device.

Please let us know with this is fixed.


#13

same thing here, Boron LTE was paused when reached 2.5MB and the set data limit is 5MB.


#14

@jaafar @fishmastaflex @TimGTech @jimbol @wesner0019

As part of an ongoing investigation, we are still looking into this issue. As you are all able, could each of you please provide me with an ICCID of SIMs you are having difficulty with and the issues you experienced (pausing prematurely, taking a long time to unpause, etc).

Feel free to sent these to me through DMs.

Thanks everyone!


#15

Hey guys,

A bit of an update on this.

We are still investigating the issue but may have uncovered a potential culprit. It appears that one of our partners recently updated the way data records are handled. As such, for a limited period, some records were being accounted for twice for some users… This may have caused some SIMs to pause around prematurely.

It’s believed that the embedded SIMs in the E Series LTE, Boron 2G/3G, and Boron LTE all may have been affected by this. It is not believed that our external SIM (such as the ones provided with the Electron) and that the Electron 2G/3G were affected.

There also were a few identified SIMs that may have been charged twice. All identified customers have received refunds for this. If you believe you were one of the affected customers but did not receive a refund, please reach out to support and reference this post.

For all of you who have been experiencing issues pausing and unpausing, please try unpausing your devices now.

Please note, that for these devices, this carrier can sometimes take longer than usual to process SIM card unpause requests. In extreme cases, it can take up to 3.5 hours or longer.

Our console has not yet been updated to handle SIM requests that take this extreme length of time (but it’s being worked on!). In the cases where you receive a SIM activation failure on the console, the best option in this case is to not try activating again. It’s likely the request went through and that you will simply need to wait a few hours. Once it is active, it will show up as such in your console.

Should you continue to experience issues after unpausing your SIMs, please feel free to send a message referencing this post and include the behavior and ICCID.

Please feel free to post any questions or concerns here in regards to this here.


#16

I woke up to a Paused Boron LTE network that had a 20MB data limit but the SIM was only at 11+ MB.

I unpaused the sim but it has not reconnected as quickly as last time so I am seeing the unpause delay you are talking about.

The SIM forced me to update to the 50MB limit before allowing me to unpause the card. Even though it was showing me data usage at 11+ MB.


#17

If my device is at 4.6mb and I have a 5mb limit shouldn’t I be able to unpause it without having to up the limit to 10mb?

Also it seems that while the device has been paused, the usage being reported has gone up. I’m guessing it has just taken time for the reporting to catch up.

It might be a good feature to add to be able to set a warning limit. That was folks will get a warning at a certain usage limit but not pause. Ability to set a warning limit in addition to a pause limit.


#18

Hi RWB,

This falls in line with the issue we were seeing. It looks like our console is displaying the proper amount of usage on the console, BUT the calculations on the backend take in account of the duplicate records.

If records are all doubled, it’s likely why it was pausing at 20 MB, since the system was believing 22 MB of usage had occurred.

I’m going to follow up with engineering with your ICCID to see what more they can find out


#19

Hi Tim,

Yes, you should be able to. Due to the nature of this bug, however, our MVNO has effectively reported double records to us. Our console displays usage correctly, but in the background the system believes double the amount has been consumed–hence the unnecessary pausing.

To add in complexity, the MVNO responsible for Boron LTE, Boron 2G/3G Global, and the E Series LTE has significantly delayed reporting. In most cases, we are seeing 3-4 days, but in extreme cases can be in excess of a week.

A warning limit does exist, but I’m afraid is ultimately moot with significant delays on reporting. We are actively working with our MVNO to lower this reporting gap, however. But, as this is not an internal system that we are responsible for, we cannot make any timetables as to when this will be overhauled.


#20

Hi All,

I had a paused SIM last week, which appears to have paused due to legitimately going over its limit. I’m not sure why the usage this month was so much higher than normal, when other units in the same vicinity and same firmware did not have the increase, but the bigger issue I faced was that after unpausing, the unit did not begin reporting again without going out to it and manually reseting. A bummer because it’s a very remote location.

When I got to the electron, it was waking and trying to connect as expected, but would time out after 120 seconds and go back to sleep. I put it in safe mode in order to get it going again. It took much longer to reconnect than it does from a normal start. I didn’t get it timed, but I suspect it was close to 5 minutes.

My firmware tries to connect to the particle cloud for 120 seconds before going to sleep. This is due to a prior experience of running the battery way down trying to connect all night during a cellular outage last summer.

120 seconds has always been adequate even when starting a unit which has not been connected recently, or in the same area. However, 120 seconds is not adequate to get my electron connected to the particle cloud at my location after unpausing the SIM. I have fair or good reported cellular signal, and my time to connect, read my sensors, and publish this data is typically 7-9 seconds, so I don’t feel this is related to poor signal strength.

I’m now changing my firmware to have it try to connect for up to 5 minutes once a day during sunlight hours (this is a solar charged unit), to hopefully prevent this problem in the future, and give it enough time to connect after the unpausing of the SIM.