SIM activation fails (over and over) with "Temporary Activation Problem"

Just received my Electron. Was psyched to see the slick first time user experience…a shame it does not work. I get an error at SIM activation that says "Temporary Activation Problem. There was an issue activating your SIM. Please try again later."
I’ve tried multiple times. Is there a workaround for this? Any idea how much “later” I should be trying?

Could you post a screenshot?

@jonsm, i received information from the team that there’s an issue with the telephony partner so SIM activation might be impacted.

Will update when i have more information.

Thanks for the update and for keeping me posted.
Screenshot attached.

@jtzemp might be able to provide new updates when it’s available.

Hey, @jonsm.

I noticed in the logs that your call to activate your SIM failed. The response we got back from the API call was that they were doing a backup on a database. They didn’t schedule any maintenance with us, and I’ve pinged them about unscheduled downtime. I’d suspect if you give it a few minutes, you’ll be able to activate your SIM w/o problems. This type of an issue would only affect SIM activations/deactivations and so far, you’re the only one we’ve seen get an error.

Go ahead and try again, and if it doesn’t work, give it 10 minutes and try a second time. I’ll check back and check the logs periodically to make sure your request made it through.


I just tried it manually with one of my SIMs and it worked for me. Looks like you should be good to go to activate your SIM.


Cool. Thanks for letting me know. I just retried and SIM activation completed. The rest of the workflow was really smooth. Thanks!