Signal, Ping, Variables and functions greyed out in console


couple months ago I noticed both functions and variables stopped working in console for my argon if I used the console using Chrome from phone. They did however work by signing in using Chrome in laptop. Today signal, ping, functions and variables are greyed out even when I sign in using laptop. I hadn't update firmwire for months, so did that but it didn't make a change. Events are getting published ok. Then I tried from CLI and both variables and functions work from there. This looks like console specific bug?

My code is very simple and hasn't changed for couple years (system thread is disabled, literally following basic hello world examples):
void setup() {
Particle.variable("DS-Temp", dsTemp);
Particle.variable("Last-Update", lastUpdate);
Particle.variable("Set-Temp", heatSetting);

Particle.function("heater", cloudHeater);
Particle.function("temperature", cloudSetTemp);

etc... all has worked well and CLI still works for all the variables and functions.

Any clues what could be wrong? Bug in Particle's console?

also I just published a new variable to make sure that works and yes it did show up in the console but clicking on get does not give a response. CLI works for that new one too.

Hi @mato!
Thanks for the heads up on this. I'll let the team know about your issue. Can you help me with the following?

  • What OS is your phone using?
  • What is the current Chrome version installed on your phone?