Serial err: Error: Opening COM1: File not found

I am using Windows 10 and I was playing around with particle device doctor for some other issue. However, now I am not able to change the settings using the particle doctor as it is throwing up serial error. I am able to flash tinker but I am not able to connect to the internet. I guess I have made some mistakes while changing the network details. I need to reset them to their original settings. Is there a way to do that?

ScruffR: I moved the conversation from the other thread here as my reply to that thread was already addressing this
See discussion bellow

And how do you fix this issue. Flashing another app is not working. Even flashing tinker isn’t working. It’s saying device not discoverable or offline even though my device in DFU mode. And after pressing reset, it is blinking cyan!

How do you try to flash in DFU Mode?
What does particle binary inspect <firmware.bin> for the binary you intend to flash say?

Can you provide a video of that (min. 30sec)?


And also, while reseting using particle device doctor, it is throwing up serial error after the antenna selection part.

Can you also provide the particle serial inspect output?
You binary seems to be targeted at a rather old device OS version.
The two orange blinks (at 0:26+) provide a hint about the problem - that’s the reason for 30+ video to get more than just

The colours that go beyond the expected cyan blinking are of interest!

This is what it means:

This may point to a firewall issue.
Can you try a different WiFi network (e.g. mobile hotspot)?

I have actually tried a different wifi networks but to no wain. I think I have messed around somewhere in the particle device doctor settings while putting in the network settings. Can you guide me as to how to use the doctor for a successful setup.

And also I am having problem using the device doctor. The serial error is still persistent

Ans also while doing a serial inspect I am getting a serial error.


I don’t use particle doctor. I prefer doing things step by step myself.

I’d try these steps

All of the following in DFU Mode

  • particle update-cli
  • particle flash --usb tinker -v
  • particle update -v
  • particle flash --usb tinker -v
  • particle keys doctor <yourDeviceID>
  • particle keys server

If that doesn’t help download the following

Then aply

  • particle flash --serial bootloader-1.0.1-photon.bin -v (in Listening Mode)
  • particle flash --usb system-part1-1.0.1-photon.bin -v (in DFU Mode)
  • particle flash --usb system-part2-1.0.1-photon.bin -v (in DFU Mode)
  • particle flash --usb tinker-1.0.1-photon.bin -v (in DFU Mode)

After that try particle serial inspect (in Listening Mode) again.

If you had - at any point - set the device to use a static IP and/or external antenna then you need to flash some firmware that sets these changes back to using dynamic IP and “internal” antenna.

1 Like

After updating the drivers I can’t detect my photon in the device manager

And where do I find this??

In the docs here
and here

Have you checked both these boxes

Also try a different USB port and cable.

1 Like

I have actually checked both the boxes and removed the older one before installing the new one. I am able to see my device in device manager but the serial error still shows up when I try getting a particle serial inspect

So I was able to get the serial inspect after reseting my IP settings back to dynamicIP, however, I’m not yet sure how are both of them related!

There shouldn’t be a connection between dynamic IP and serial, but the two orange blinks can be explained by that.

Hey @ScruffR

How do I change the bootloader version of my photon? The bootloader and the module version don’t match and probably due to that my photon is not leaving the setup mode. Even after reseting it. And even after configuring it with my wifi.

You’d download the respective bootloader binary and flash that in Listening Mode via
particle flash --serial <bootloader.bin>

Hey, before this I tried with particle update and the bootloader did get update. However, the problem persists. Right after sending the first json packet the wifi creds are getting reset. I have actually created another issue regarding this here