RGB not displaying anything, cannot reset

So I’m very new to all this, receiving the inventor’s kit for photon yesterday as a gift. So I was just about to start working on the first project “Hello world” and had the IDE open, and incidentally clicked the flash button when “blink an LED” example app was open. Now the RGB LEDs don’t show anything, the D7 led is on, and I cannot reset the Redboard. I’ve looked around to find anyone that had a similar problem, but I couldn’t dig up anything. Any help would be appreciated!

A couple of quick questions:

  1. Can you put the unit in safe mode?
  2. Can we get a picture of your setup?
  3. How are you powering your hardware?

Can you put the board into Safe Mode?

Press and hold SETUP/MODE and tap RESET - as soon the RGB LED shows magenta release SETUP/MODE.

I tried, but it didn’t seem to change anything. Nothing flashed or anything…

Can you enter DFU Mode (hold till yellow appears)?

Any chance to post a video when doing the Mode selection?

No, i cannot get to DFU mode, I’ll send a link to a video shortly

No, I can not put it in safe mode. I just posted a video that shows what I have going on, and I’ve tried powering it with a battery and with the micro USB.

If you can measure the voltage on the /RESET pin, it should be 3.3V when the RESET button is not pressed, and ~0V when it is pressed. Maybe the RESET button is broken and holding the board in reset?

If you don’t have a meter, you can put a jumper in the D7 pin, and connect that to the /RESET pin. If the dim D7 LED turns off, the RESET button is shorted to GND.

If the D7 LED gets a little brighter, the pullup on /RESET is powering the D7 LED a little more… then if you press RESET button it should turn off the D7 LED. In this case the RESET button seems to be working fine and you probably have a bootloader issue which would be best resolved by using JTAG tools or getting a replacement board.

If it’s a bootloader issue, I’d appreciate as much detail as you can provide about your setup experience. Was it connected to the Cloud first? What tools are you using besides the Web IDE?

1 Like

This seems to be my case. The D7 gets a little brighter and turns off when I hit reset

I had it connected to wifi and the cloud (it had a turquoise breathing light) and the only other thing I used to interact with it was the Particle app for android. I was able to use it and see if the board was online or offline and turn on and off the D7 LED. The D7 LED was off before I ran into this issue. Right beforehand, I had pressed the reset button and had a solid white light, and then (being new to all this) I pressed the reset button again, thinking the solid white light was odd (because in my past experience, it would change within a few seconds), which then put it in the state it is in.

Interesting. Were you using SYSTEM_MODE(MANUAL) before hand and maybe that’s why it was solid white? Was it breathing white or stuck solid white for many seconds? You’d have to stare at it for a while to know if it was breathing white or solid white. If breathing white, that’s usually due to being in MANUAL mode with the Wi-Fi off. If solid white that could indicate some kind of a lockup.

Try to see what Sparkfun support can do about a replacement if you don’t have access to a JTAG programmer.

No, I don’t believe I used SYSTEM_MODE(MANUAL) before hand. The only thing I flashed was the provided example program, which (when you get rid of the comments) looks like this

I suppose it’s completely possible that is was blinking white. I’ll see what Sparkfun can do for me; I’m not sure I know what a JTAG programmer is and I definitely don’t have access to one right now.

Can you take a look and see what version of firmware you last compiled for your device? Also would you PM me the device ID? Thanks!

1 Like

Sorry for the delay! It says “on this device: 0.4.4” for the firmware, and I can’t seem to find how to pm you to give the device id…

@rojay,

Click on @BDub’s name and click the blue message button.

@nrobinson2000, am I missing something?

It appears that your account is too new to PM someone. @BDub should start a PM with you.

In fact, I did just that previously…

but I’ll go and enable PM mode for you as well @rojay