Dead Photon with Led D7 On

Hi guys,

Yesterday I updated my firmware photon to 0.4.9 and today I was trying to run some app. The app that I was trying to run was the example “blink the led”. When I flashed it, my photon was blinking magenta continuously and suddenly it stopped. Now, it is not showing any signal or blinking led.
I’ve tried to put in the safe mode, but the setup and reset button are not working. The photon stays with the D7 on.
What else should I do?

Thank you.

Nasty… hold the SETUP button and plug the usb in. What happens?

1 Like

Make sure there’s no external circuitry attached when trying that. Also, ensure your got a proper power supply, and a good USB cable. Wouldn’t be the first time that messed things up.

1 Like

Kenethlimcp… Thank you for replying. I’ve already tried this. The photon doesnt give me any sign that is working.
Moors7… Thank you for replying. My photon is in the breadboard without any other component and my usb cable is the same that I use in my other photon (that is working) and the power supply is my laptop.

Any other advice?



Is the blue LED brightly lit or dimly lit? Dimly lit means the debugger port is active. You can try connecting D7, D6, D5, D4 to GND to force all debug signals to an off state (make sure no other components are connected to these pins). Then power on the Photon and try safe mode.

Also try the Photon outside of the breadboard. Maybe there’s a bad connection in your breadboard?

The blue led is dimly, so I tried to connect D4-D7 to GND. The blue led now is off, but I’m not able to enter in the safe mode.

The breadboard is working fine, because I tried the same breadboard with other photon in the same position and it is working.

can you put the device into DFU mode and issue particle update from the CLI (this will take your firmware to a version of 0.4.9) and let’s see if the issue still persists from there


I’m not able to put in DFU mode. The setup and reset button are not working. Is there any other way to do it?
As a reminder, the laptop is not recognizing the photon, it says the photon is disconnected.

reaching out to you now in a private message.

If you can keep this thread public that would be great as I’m having similar issue. Thanks!

OP, had this issue once and I found out it was from some kind of flaw in the handing of the photon or the placement of the heat spreader. This flaw could be either by myself or production because it was intermediate. My fix was simple.

Get your hands on some precision Suface Mount sharp tweezers, and a magnifying glass. Check around the left side of the heatspreader for where it may be touching the wrong parts. ( hopefully someone from Particle can help us on what is the right parts) gently bend it upward slowly and attempt to power on, but NOT which you have the tweezers in there. I successfully recovered from these same symptoms, by fiddling with this idea.

My guess is the next step is JTAG, which may be what the Particle engineers want to keep private. This is understandable.

[the heatspreader is the laser etched Particle metal piece in the center of the unit]

Any solution to this problem? Same situation here…

If you update the system to 0.7.0 (currently RC6) before this problem hits the device should be able to heal itself.
If you hadn’t you’ll need to go the JTAG/SWD way :wink:

I am having the same issue, i emailed particle support but i didn’t a response yet. How can i fix this issue? i tried updating the firmware but the setup and reset button are not working can’t put it in DFU mode. Only the D7 light is dimly lit. Can you please help ???

I think this is similar to other posts regarding the dim blue LED. It would require a JTAG programmer to reprogram the bootloader:


Or use a secondary photon with the Norweigan Blue code to reflash the bootloader?