[RESOLVED]Cannot create a new webhook

Hi All,

This is one a Spark Core. With all updates applied.

So this PM I tried to create a new webhook but am getting this back from the CLI. Here what I did

particle webhook create MonitorDoorNo1.json

I get back the following with some edits to keep

*Sending webhook request  { uri: 'https://api.particle.io/v1/webhooks',*
  *method: 'POST',*
   *{ eventName: 'MonitorDoorNo1',*
     *event: 'sendSMS',*
     *url: '<Valid URL is here Really',*
     *requestType: 'POST',*
     *headers: { accept: 'application/json' },*
      *{ action: 'create',*
        *token: 'Valid Token from my other cloud service',*
        *number: '{{n}}',*
        *message: '{{m}}' },*
     *mydevices: true,*
     *deviceid: undefined },*
  *headers: { Authorization: 'Bearer 8fc0e48d5aa1308fcc12df74c9fb266393011f1f' } }*
*Something went wrong, server said:  Timed out*

So I am sort of stuck. I only have two web hooks set. My partner that the hook get works with seems happy.

Any suggestions / comments are welcomed.


Never Mind!

I just executed the same CLI command and I was able to create a webhook.

I also noted that my previous attempts must have worked even with the message that the server timed out.

So all stand down for now.


1 Like

There was an issue with webhooks during the time you were trying this if I’m not mistaken.
Here’s some more info: http://status.particle.io

1 Like

Thanks for the note. Yep was my issue.