Can't create webhook on Particle Console [Solved]

Well, all was well yesterday, but when I tried to create a webhook today through the Particle Console, I entered a perfectly normal URL and got the following message:

URL must be a valid HTTP or HTTPS endpoint

The Create Webhook button remains disabled, and so no luck.

Good news is the good ol’ trusty particle-cli still works, so I’m not stuck. But thought you’d wanna know.

Cheers,
L3

what is the url you are using?

@kennethlimcp,

Would rather not say, but suffice it to say that I used the exact same URL in the particle-cli create webhook command and it worked swimmingly. And it is functional. So the problem is almost certainly with the HTML validation on the Particle Console website, not with the webhook infrastructure of my (admittedly questionable) URL composition skills.

Cheers,
L3

did you put a http or https at the front?

ping @jeiden

https

@leo3linbeck – please let us know the exact URL you are trying. If it contains sensitive info, you can always DM me.

Thanks,

Jeff

2 Likes

Let us know if you can get your webhook running @leo3linbeck.

@leo3linbeck So the issue is with the front-end validation of the URL on the console, which included _com. The underscore + the presence of com is what is causing the validation to fail. This seems like a pretty rare case, so for this one it may just be best to use the CLI to create it.

1 Like

@jeiden,

Thanks for running this to ground. Kinda weird, but what you suggest makes sense. Like I said, the webhook is up and running fine, just had to use the CLI. Another quirk in the wonderful world of software engineering! Cheers,

L3

1 Like

Thanks @kennethlimcp @jeiden for the help!