[SOLVED] Webhook creation error

I’m having issues creating a webhook from the CLI in Windows. I have tried the same JSON on 2 different machines so far (Windows 10 Preview and Windows 8.1). When I run:

> particle webhook create webhook.json

I receive the following output:

Using settings from the file webhook.json
Please specify an event name

Below is the webhook.json file I use:

"eventName": "ConnectTheDotsNLSS",
"url": "https://ctdnlss-ns.servicebus.windows.net/ehdevices/messages",
"requestType": "POST",
"json": {
    "subject": "{{s}}",
    "unitofmeasure": "{{u}}",
    "measurename": "{{m}}",
    "value": "{{v}}",
    "organization": "{{o}}",
    "displayname": "{{d}}",
    "location": "{{l}}",
    "timecreated": "{{SPARK_PUBLISHED_AT}}",
    "guid": "{{g}}"
"azure_sas_token": {
    "key_name": "D1",
    "key": "yrDSWExkzKKZY9uBWALhMyOjVfGOyjiczv8eNAgXM8s="
"mydevices": true

The first message indicates it does find the json file in my folder. Obviously I do have an event name too, and I made sure all the double-quotes are standard and not “international” or mismatched. Is the problem my JSON or my CLI setup?

Thanks for your help,

Try changing eventName to event, that might work :smile:.


That worked!!! Thanks! Is this documented somewhere and I missed something obvious, or this is an esoteric bug/omission?