Cannot create or edit webhooks

Hi All,

Is anyone else having trouble with the Webhooks area of Integrations in the console?
I’ve been trying to edit a webhook, but I get a message “Bummer! timed out after 3000ms” the first time I try to save my changes. If I try a second time, I get the little spinning circle that indicates it’s doing something, but it never gets past that.

If I try to create a new one, I get:
“Bummer! Integration creation failed: timed out after 3000ms”

If I try to delete a webhook, I get “Bummer! undefined”

I’ve logged out and back in again, and rebooted my computer, but no change. I also tried a different browser. Is there an issue that isn’t reflected in the status page?

J

1 Like

Yep, just got the same error…

I’m having this problem as well.

In case anyone from support is watching, I get the same result trying to create one via the API, which makes sense, since that seems to be how the web UI does it:

curl "https://api.particle.io/v1/integrations?access_token=redacted" -d event=test -d url=https://test.com -d requestType=GET -d integration_type=Webhook
{"ok":false,"error":"Integration creation failed: timed out after 3000ms"}

Update: tried the CLI as well.

@jimbol, @supscientist, @vespa59, can you check if it’s working again?
For me things came back just a few moments ago.

1 Like

Confirmed it still occurring

1 Like

We’re investigating a problem creating or editing webhooks and other integrations. I’ll let you know when I have more information.

Rick @ Particle

4 Likes

Still the same behavior here at 0730 Mountain Time.

The inability to create or edit webhooks and other integrations (Azure, Google Cloud, etc.) should be fixed now. Sorry for the difficulties.

Rick @ Particle

1 Like

Back in business! Thanks,

1 Like

Confirmed working. Thanks!

1 Like

Ditto.