Reclaim Photon device failing?

Hello,

I am brand new to this and not that skill in tech. However I purchased a Game Frame pixel art picture frame and bought the Photon Particle wifi adaptor that goes with it.
I logged into it as per the simply set up and made a light blink etc. Then uploaded of new Game Frame firmware onto it (think this part may have gone wrong)… as when I then swapped it with the chip in my Game Frame… it does not turn on or work?

I decided to try the setup again from the start. So deleted the device from my Particle app and the. Went to restall it. However during the setup it gets to ‘reclaim this device’ and when I click yes… it fails??

Can somebody please advise or give me some instructions to reclaim?

Thanks

Andy

1 Like

You can try claiming the device Web IDE or CLI but in order to claim a device it has to be online (breathing cyan or magenta).
If it doesn’t reach breathing cyan you may need to put the device into Safe Mode.

1 Like

Thanks for the reply… when i plug it in and try the process again. I get a blue light and a white light in the middle.
I am able to put it into safe mode by holding the set up button.
I then use the app on my phone to find the device, add it, hook it up to my wifi.
But then it goes through a check list and fails at the last step which is reclaiming the device??

The very first time I tried to set the device up… i assume I claimed it as my device?
I was able to rename it and get it to flash a light, but it I think the firmware update I then did failed or never completed?

Is Reclaiming a device just registering it to your account?

I have just manage to flash the device and got it set up on the app again.
However after downloading the Game Frame firmware onto it, i plugged it into the game frame and it lights up blue but does not turn on the device?
Any ideas??

Did you flash the prebuilt binary from their repo or did you download the code, build it and flash that way?
What tools did you use for the involved steps?

What lights up? The D7 LED, the RGB LED on the Photon or the matrix display?
What kind of blue (dark blue like the D7 LED or the rgB LED, or more like cyan)?
Is it steady, blinking (fast or slow) or breathing?

We can’t really know what you are seeing unless you exactly describe it or post a video.

BTW, there are so many projects running around - posting a link to your sources would really help (and save us the time to go searching).

Thanks again and apologies for the basic level of my updates!!

I used the faq guide on th Particle site. I tried to reset the device by holding both buttons the. Releasing reset but keeping set up held down until the RGB flashed yellow.
However it never went onto flash white and remained flashing yellow.

I then used the Windows Powershell window to type commands in.
I managed to login and I then used the flash command. This seemed to work and the D7 light went off and just the cyan RGB light was as on.

Thinking I was back at square one with a re flashed Photon. I followed the setup up procedure from

https://ledseq.com/game-frame-wi-fi-adapter-documentation/

This worked fine and I had no problems reclaiming the device and giving it a name etc

After uploading the bin file updated firmware onto the Photon the update only took a few second and when the Photon reset. The D7 was blue solid and the RGB was white.
I’ve plugged the Photon into the game Frame and when it is plugged in I only get a blue light on D7 I think. I will try and take a video or piture of It tomorrow to post.

That’s due to the fact that the Photon does not feature the Factory Reset feature you probably read about in the Spark/Particle Core docs.

Ok must have missed that!
Thanks for letting me know.
So when I typed the flash command… does that completely reset the photo?
Is there a way I can check the software that’s on it after I’ve done the firmware upload with Game Frame firmware… but before plugging it into my game Frame?
Should I be getting a white light once the upload is completed along with a blue D7?

No. The Photon has (at least) three firmware modules (2x system, 1x application - plus some others).
So to fully “reset” a device you’d need to flash all three of them (and maybe even the bootloader).

But that’s not complicated when you have CLI installed - which goes as the Swiss Army Knife for Particle devices.

The white light only indicates that you are not WiFi/cloud connected. If this is the intended behaviour of the application that’s by design.

But to know for sure, you’d need to look into their code (which is open source) - which also opens the way for your own tweaks to the system.

Maybe we can also get @Jerware to chime in so that he can learn about your issue. Maybe he can provide some guidance from his side and also get some benefit for future customers.

Meanwhile you could connect the Photon via USB to your computer and see whether the serial output sheds some light on the issue.

Thanks, @ScruffR. Andy and I have already discussed this on my company forum a few days ago. The adapter he bought was assembled incorrectly (not by me!) and he has ordered a replacement. I use a small PCB to convert the Photon pinout to Teensy, and the Photon was soldered to the board facing the wrong direction. @fbz1501 have patience, man! Let me know when the new board arrives, and let me know how it goes. We’ll figure this out.

By the way, if you just want to see if you have the firmware flashed correctly, just plug the Photon into USB (not into the Game Frame). Then find out what its local ip address is by checking your router and going to this url:

http://your.photon.ip.address/help

It should load up a help page. Maybe there’s an easier way to find its local ip address, but I always just check my router. Or just load up a serial client (like Putty) and use it to read the debug output from the Photon when it boots up. But really, if I were you I wouldn’t sweat it – just wait for your replacement board and let me know how it goes.

2 Likes

Well my replacement Photon arrived today and is built correct and works great in my Game Frame.
Got it set up straight away!!


Thanks again for the help and support.