PuTTY equivalant on a Raspberry Pi

I finally got PuTTY to work on my PC and used SerialWrite to monitor and debug a project. I have a couple different Photon projects in parallel and I would like to use my Raspberry Pi in a similar way - that is hook up the Photon via USB and be able to see serial output from the Photon. I’ve done a fair amount of searching and can’t find much help. What I do find doesn’t seem to work. For example, I tired what was suggested here Particle CLI on Raspberry Pi? and it locked up my RPI. (I finally got back to a command screen, but it has taken almost 10 minutes to respond to “sudo reboot” :worried:)

Is there a serial terminal like function on a RPI USB port? If so, a pointer to the steps would be much appreciated.


sudo apt-get install putty

1 Like

Thank you bpr. I think I got it installed, but I did have to to sudo apt-get upgrade to get a couple libraries. Although I have Ubuntu on a machine and now the RPI, I am still pretty uncertain with Linux. I can’t figure out how to make putty run. I have tried using the “Run” in the pull down and get "Failed to execute child process “putty” (No such file or directory)" I tried locating putty with "dpkg -S putty | grep -E “(bin/)?putty$” and running it from there using “sudo” and get command not found

In addition, I am still not clear on how I get a USB port recognized/connected.

I don’t expect a Linux/Raspbian tutorial here, but would really appreciate a pointer to some useful information. I have done a few hours of searching and reading and most of what I find on PuTTY && Raspberry Pi is using it on a Windows machine to SSH to the RPI. I have a stand-alone RPI with keyboard, mouse and monitor and am trying to use it to connect to my Photon.


Caveat: Linux is a stretch for me, too. All I can tell you is what I’d do, FWIW.

In a terminal window on your pi:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install putty

if that doesn’t work, then it may be easiest to just reinstall the whole operating system after either cloning the sdcard for safekeeping (“SD Card Copier” from the Accessories menu) or first copying any valuable files to a usb thumb drive. Then try the above again. I think your system may be broken somehow.

PuTTY is a Windows application. You can’t (as far as I know) sudo apt-get install putty on a Raspberry Pi.

An easy way to view serial port data on Linux is to simply run tail -f /dev/ttyS0 (or /dev/ttyACM0 or whatever device is created when you plug the Photon in.) If you’ve not changed the bitrate it should work, if memory serves.

Someone will hopefully correct me if I’m wrong.

edit, later: try cat /dev/ttyACM0 - that should give you the output from the Particle device, provided that is the serial port that is created. It probably will be.

On unices it’s called ssh

you don’t SSH to a serial port. The topic originator wants to see the serial output from a Particle Photon connected via USB. That’s a software serial port. That’s /dev/ttyACM0 or whatever.

Whoops ! My bad.

Then you could install screen.

sudo apt-get install screen

1 Like

OK, thank you for the correction.

Why in the world is PuTTY available on Linux?

HooYaa!! I don’t know why I have to try everything 2 or 3 times, but, after it didn’t work this morning, I tried “sudo apt-get install putty” again and it worked. (?? :confused:)

Anyway, the window came up just like bpr showed. I used /dev/ttyACM0 at 9600 and yureka!!

Thank you all.


Good question. Obviously the developers thought if it was good enough for Windows users, then *nix should have it too! Plus they point out that in porting it they fixed quite a few bugs that they re-discovered… so it benefited everyone! :wink:

1 Like

As an alternative to Putty you can use Minicom on linux. If it’s debian based, sudo apt install minicom. You might have to enable the Universal repository first though with sudo add-apt-repository universe. You can use it by typing minicom -b 9600 -d /dev/<serialdevice> I believe. Double check the arguments, however, with minicom --help.

1 Like