I can't see serial data in Putty... but It appear if I use CLI

It is strange because it worked perfectly from the begining, but suddently it stoped working.

The computer recognises perfectly the photon and gives to it a serial port.
Even I can connect to the COM port, but nothing is seen in the terminal, It appears that I am not getting anything. But when I try “particle serial monitor” the magic happens.

I think it could be involved with CDC drivers but I don’t know how to solve it, any idea?

Edit: I tried to Enable DTR and it works now but still it doesnt work on Atom serial monitor…At least I can see it now, but it would be great some light here

What does your code look like, and are you using the correct Baud rate?

For USB Serial the baudrate is irrelevant (unless you set one of the magic ones 14400/28800 - but that would result in entering DFU/Safe mode).
Also if one program can receive data but not the other it’s probably due to some issue with the not working program rather than an issue with drivers or device.

Some more background info is required to better understand your actual setup and issue.

It might be a timing issue tho’.
Since PuTTY can’t auto reconnect you might get a first connection which immediately gets closed from the device for some reason.
So try connecting PuTTY a while after startup and see what that does.


My50 ct: is an USB-HUB active? What happened by using TeraTerm instead of PuTTY?

It was just that the port needed to have DTR enabled to display things.
The only configuration i made is calling the begin function…

Probably the CLI configures the connection automaticaly to ear the device and with other programs its not this way, you have to try to open the port with a specific configuration.

If DTR is not enabled the connection will be possible but you won’t get nothing on the terminal.

I spent almost one day installing drivers, unistalling etc. At least I expect this postto be useful for other users