Problems with and Particle IDE [Solved]

Is anyone else having trouble building? It was working fine for me as of yesterday, but today, I can’t build anything from or from the Particle IDE. Specifically, I can’t build anything that references a library. I get errors like:

blynk.cpp:22:25: fatal error: blynk/blynk.h: No such file or directory

While I know the library is there.

I tried a different project that uses the neopixel library. If I reference it as “neopixel/neopixel.h”, it fails in the same way, but if I download neopixel.h and neopixel.cpp to my project folder and use the IDE, it works fine.

I tried the same with the original project I was working on; it used the blynk library and the Adafruit ADS1x15 library. By downloading the files from both libraries and referencing those files, I was able to get a good build. But upon flashing, my Electron breathes cyan, so there’s obviously something wrong with the resulting firmware.

If I’m doing something wrong, I can’t figure out what it is. My first build today was after one small change, which I backed out to get back to the code that was building just fine yesterday, but the error remains the same.

Can anyone confirm that they are able to do a build on and/or the Particle IDE that includes a common library (i.e. not all source code files are included in the project folder)? If you are able to build successfully, please include what country you’re in (as prior issues like this have been reported to be local). I’m in the US.

I can successfully ‘verify’ (compile) a program which contains blynk:

#include "blynk/blynk.h"

at in New Zealand with default firmware version 0.5.3. What firmware version do you have set at

Hmmm. I’m actually running 0.5.2 (which was working fine yesterday), but even if I set the “compile to firmware” option to 0.5.3, I still get the error. To be clear, I’m doing this from the drop-down list under my target Electron on the “Particle Devices” panel. So maybe it’s a US issue?

Thanks for checking!

@Eric24 is the library added to your app in the Build IDE? You need to make sure you added it through the libraries tab

1 Like

Crazy! I had originally done exactly that (and it was working fine). Then the first time I tried to build today, it failed. I just removed the #include lines for the two libraries I was using, then re-added them as I had before, and now it works! It appears that it somehow “forgot” that I was using those libraries. Very strange.

Thanks so much!

1 Like

Glad your up and running again @Eric24!