Neopixel & MPR121 library does not work on Particle Build

It seems there is an issue with the new library update, several verified community libraries are not working on Particle Build (but they do work on Particle Dev.)

For example, when working with Neopixel, it shows this error message now:
lib/neopixel/examples/a-rainbow/a-rainbow.cpp:8:22: Particle.h: No such file or directory

Can anyone point to the solution to this problem? It seems Particle Build tries to also compile the code in /examples, which is unnecessary.

Whatplatform and system version are you targeting?
For me NeoPixel library v0.0.13 builds for Electron 0.6.2 & Photon 0.6.2 without issue.

What library did you use for MPR121?

I tested it on Neopixel library v0.0.13 with Photon 0.6.2.

Try this then again

This used to work and still does.

This is the error message when flashing the code on Particle Build:

That brings me back to the question I alread asked earlier

The 0.6.2 in the bottom right corner does not tell what version you are targeting but only what version is on your device currently.
Check the target setting in the Devices (cross hair icon) drawer.

Having the same issue, I found this thread and took a closer look at what was going on for myself. My Electron had firmware version 0.4.3 on it. When I tried to upload my firmware which was targeting 0.6.2, my device went into safe mode blinking magenta.

I downloaded the two firmware managers 0.5.3 and 0.6.0, using one then the other. This got my loaded base firmware to 0.6.0. I changed my firmware target in the IDE to 0.6.0 and downloaded the firmware for my program.

Testing now but it appears to have solved the missing library issue.

Firmware Manager Page

@hugh, That’s awesome. I haven’t got time to test the solution out, we come back to it a few days later!