Particle_rf library doesnt work under new firmware 0.6.1?

Hi fellows,
I work on the Particle Photon and a nrf24L01 and i use the ported particle_rf24 library.
Before the last release everything worked fine with 0.6.0 version of the firmware, but something happend with the new 0.6.1.

I should mention again, that everything compiled and worked before, but now my project cannot be compiled.
I work with the particle dev Atom IDE and also with the particle cli.
Here some screenshots about the compiler errors.

I also tested the particle_rf24 library again in the web ide on an example, even that i was not able to compile.

I am very sure, that there is no failure from my side, but maybe i missed something.
Please help!!!

Particle-cli[snaphot]

Web-IDE[snaphot]

We do prefer error logs and code in text rather than looking at screenshots.

And to report an issue for a specific library it’s best to open a GitHub issue on the contributors repo.
Not all contributors are that active on the forum and read all the posts (as we mods do), so explicitly pinging the respective member would be required too.

The reason for this build error is that SERIAL is a predefined “keyword” in 0.6.1 Arduino compatibility headers, so it’s not free to use in the lib.
This might be solved once similar issues get addressed in 0.6.2

I also have a library that will now not compile with 0.6.1 firmware due to the Arduino capability features.

Do you have any idea when 0.6.2 is slated to be released?

1 Like

Sorry, didnt know where to find the forum rules :wink:
I will keep that in mind for the next time.

I solved that problem in a siimple way,
downloaded the particle_rf24 lib and only renamed the the problematic names, like SERIAL function to RF24_SERIAL
BV_ macro tor r24_ BV_ and pgm_read_word(… macro to rf24_pgm_read_word.
I could solve that locally , but there is still the problem in the WEB IDE,I think the online library
could not be changed, If Iam right.
I will send a message to the github author of that library, I think that should be solved as fast a s possible.

Nevertheless, thanks for your help.

2 Likes

Hey guys,

So using the new 0.6.2-rc.1 firmware I am able to get this library to build and function (seemingly) correctly. I am able to use the authors GettingStared.ino (https://github.com/stewarthou/Particle-RF24/blob/master/firmware/examples/GettingStarted/GettingStarted.ino) as long as I replace the #include “particle-rf24/particle-rf24.h” line with “#include <<>particle-rf24.h>”

Where my problem arises is when I try to include the library locally (via Particle Dev) so I can see the source code. Strangely, I can still get the GettingStarted.ino to compile (though I do have to delete the “lib\particle-rf24\src\particle-rf24” directory which seems to just be left over as it simply references the directory above it as well as tweak the #include like I said above). Once GettingStarted.ino compiles though the radio simply doesnt work. This makes me think that there is a difference in the actual library code being used between when I use the “dependencies.particle-rf24=0.0.2” technique versus copying the library locally. Is this true?

Thanks!
Matt M

This sub-directory and the header files are deliberately put there by the Lib2.0 migration process in order to ensure to make old style includes still work - but obviously that’s not what all IDEs like.
But that’s already reported as issue.

Does the lib work with 0.6.0?

Particle is looking for test cases to see if 0.6.2 can be released anytime soon.
@mdma ^^^

1 Like