Strange behavior handling libraries?

I am seeing some strange behavior with libraries. Is there a problem within the Particle servers, or have I missed something since it is late at night…?

My intention this evening was to open up ParticleBuild, load up an old project and click Flash. The goal was to reload the user firmware onto my Photon and put the device back into the field (This same firmware had been running on the Photon for some time, but I was working on some other development earlier this week.)

In doing so, I got the error that the library header file could not be found.
The particular library used in my code is the Piettetech_DHT library.
I was not able to remove or re-add the library to my project.
I think I followed the standard solution to this situation. I copied my .ino file (basically a slightly modified DHT_simple.ino from the examples) into a new project and tried to add the library to the new project. In searching for the library to add, I reached the stage in the attached image, which remained in this state for at least 5 minutes until I gave up.

Wanting to get my device fielded, I switched over to using ParticleDev.
I created a new project and then clicked on the libraries button. I got this result, which never gets to the stage where I can type the library I want to search for.

Thinking about it afterwards, I used the same project name in ParticleBuild and ParticleDev. I wonder if that could mess with the system, but I doubt it since I never reached the stage of trying to compile the firmware.

Any suggestions on what I may have missed and what to do?
Any help appreciated at this late hour (for me anyways)!

Seeing as it’s working for me (I only tried Build), could you try refreshing your browser?
Could you also take a look at the console logging to see if there are any errors there (right-click -> inspect)?

Obviously that project was written before the release of Libraries v2.0.
We have been arguing about the problem that some legacy projects won’t build for newer system firmware and you can’t just replace the legacy libraries for their successors as you can’t remove the old libs.

Currently the only ways around this are either building of old system target or create a new project, copy/paste your code over and add the v2.0 libraries again.

Thanks @Moors7,

I already tried refreshing, but that did not help.

I turned on the console logging, and no issues were initially reported.
Then, I refreshed again, and the console logged the following:

This warning is at the beginning, but it makes sense:
DOM7011: The code on this page disabled back and forward caching. For more information, see:

at the bottom of the log, there are a couple of errors for
Unhandled promise rejection TypeError: Object doesn’t support property or method ‘findIndex’

That is what I was attempting to do when my current issue came up:

Bizarre! I think I am up and running again.

I saw @ScruffR’s mention of old system target and decided to check my system firmware version. I was asked to re-login to the Particle CLI and then ParticleDev started working again.

I will let you know if there is any further issue…