Particle-Dev trouble

Particle -Dev behavior has changed since last usage about a week ago. The first time I launch all is normal but subsequent compiles, or flash appear to do nothing. On initial open I can select the device, but after selecting I can not seem to change the device. I’ve tried uninstalling and reinstalling. My OS is Windows 7 Professional. I have all my libraries in the same folder as the .ino file. Any suggestions?

I can’t confirm this misbehaviour of Dev, but about this

I’d suggest you may want to try out the v2.0 project and library features of Dev.
This way, if you are using stock or contributed libraries, you won’t need to copy them to your project anymore and you’ll also have a seperation between libraries and the actual project via the dedicated lib and src subfolders.

Thanks for the suggestion. I just tried the v2.0 method. The behavior is the same except I’m now getting a build didn’t produce binary error. There were no compiler errors. I’m trying to remember if I’ve added anything to atom since the last time I used Particle-dev. I’m wondering if I need to reinstall node js.