Particle Dev breaks after first compile

All:

I downloaded the latest version of Particle Dev today. Running into an odd issue:

Whenever I open Dev for the first time and click compile, it works fine. All subsequent attempts to do any spark-related tasks don’t seem to work at all. e.g. clicking compile again has no effect. Clicking “select device” has no effect. etc.

No error messages are shown anywhere (at least not that I can see). If I close Dev and reopen it again, everything seems to work again. Once.

Any suggestions as to what’s happening here?

I am on Windows 7, in case that makes any difference.

Thank you!

Post screenshot of the entire Dev window after failed compile.

See below. Please note that the compile itself does not fail. A very simple example shown below compiles fine. But the whole editor stops working after that first compile. I have to reload it to make it work again (CTRL+ALT+R or close and re-open the program). Also note that if I toggle Developer Tools (CTRL+ALT+I) I do not get any errors there. The first (successful) compile seems to result in 3 POST requests, but all subsequent compiles seem to only produce one. though I think those are just Google Analytics calls that the editor makes for whatever purposes.

I don’t see anything. The drive name is S:, so I’m guessing that is a thumb drive or similar. Just for yucks, use the Particle Dev command File -> Add Project Folder to create a new folder on your main hard drive, then start a new project there of the same name and copy/paste this code into it.

Sure, its a lame sort of suggestion, but sometimes…

Good luck.

1 Like

Hi,

Just tried putting the project on the C drive and everything is working now! Fascinating!

Incidentally, my S drive is just another fixed hard disk, not a removable flash drive, mapped network share or anything like that. I wonder if DEV uses some crazy relative path logic to figure out the location of some of its files with respect to the project? Still seems very fragile but I am happy it’s working! Thanks so much for your suggestion!

Alex

Hi

I have just downloaded particle dev and get the same problem.
First compile works ok but subsequent attemts just do nothing no error message.
Tried the put project on C drive but no difference.
Makes using particle dev impossible.

Martin

Hi there,

I am having the same problem. Putting files in my C: drive does not seem to help.

Flashing the photon vie the web IDE works fine.

Thanks,

Alex

At the risk of repeating already said things:
Have you selected a target device?

BTW: This was most likely the issue for the OP (as the screenshot shows), but was not pointed out to him

(I also have the same issue)

the target device is selected, this is not the issue. It also wouldn’t explain why it works the first time.

That was a known bug in some previous version :wink:
But currently when building without device selected, it builds for Core by default (which seems a bit outdated, given the fact Cores aren’t manufactured anymore)

What version are you on?

BTW the next release will happen soon.

Whatever the most recent version is. Fresh download yesterday. A known bug that’s apparently a year old and completely cripples the application?

Hi @mauvai

The target is setting that you set. Some folks still use Cores and so having the setting there still makes sense, but the default being set to Core is not friendly and will get fixed.

The “works in Dev the first time” problem is often due to Particle Dev being very sensitive to extra files in the directory you are building. I would look around for any extra files, particularly “dot files” like .ds_data on Macs. You can have an exclude file that says to Dev, “don’t bother with these files” which can be helpful in this situation.

The only other file in the directory is the photon firmware binary file (no hidden files)

I’m having the same issue with Particle Dev, which I just installed about a week ago (so it’s the latest version). I did not have another older version installed already.

My workflow is as follows:

  1. Open Particle Dev, select a device, do my coding, click compile. Particle Dev compiles and returns “Success” along the bottom of the screen. It also generates a .bin file that I can upload via cli.
  2. If I click Flash, nothing happens. Compile does nothing either. No errors or other output, just nothing.
  3. Restart Particle Dev, select a device, click Flash and the firmware gets uploaded successfully.
  4. Restart Particle Dev and repeat 1-3

This is clearly not an issue with connecting to the particle servers, compiling code, or flashing because compiling and flashing all work fine the first time I open a session of Dev. Online compile/flash also works fine. I have the same issue with multilple photon devices and a core.

I’m assuming others can use particle dev without restarting it after every compile/flash, how do I get to that point?

Anyone? I’m running on Win10 if that makes any difference.

I have been trying this and I might have found an alternative explanation to “breaks after first compile”.

When I do this on my Win10 Pro 64 machine all builds do succede, but you won’t see any change in the directory tree.
If you collapse and open the tree you might see the new binary.
Or if you keep Explorer open next to Dev, you should see the binary change immediately too.
At least for me it’s more a problem with the visualisation than with the actual build action.

Could you please check that on your end too?

Thanks

See also