Particle dev will not compile


I’ve been using particle dev for several months. And i was working on the same file that I’ve just uploaded to particle core. Suddenly particle dev is not compiling. The status bar t the bottom says no .ino/ .cpp file when i hit compile button. and nothing happens regarding with any error messages and prompt error, etc.
I’ve tried rename folder rename file, delete particle dev re download and re install. Nothing worked out. Peculiarly when i remove particle dev and reinstall it, it keeps load with previous file.
Is there anyway that i can make clean install on mac? Or is there some setting that mistakenly manipulate?



I figured out why. it was upper folder name that causing the problem.

Could you please elaborate what the exact issue with your path was?
Was it blanks or “funny” characters?
Was it an overly long path?

Just to help others that might stumble over this thread in search for a solution to their own problem.

On the root of my project folder I had special character “[” !! If anyone having similar problem make sure you don’t use other characters on your folder :slight_smile:

thanks !

1 Like