Particle Dev + Blynk - won't compile

I have 2 different compile errors while trying to compile for the Electron firmware 0.5.3. I’m using the Blynk library from here and using the Particle example with the required modification in setup() that changes Blynk.begin(auth); to Blynk.begin(auth, IPAddress(45,55,130,102),8442);

The first error says it can’t find WidgetGPS.h (which is not included in the GitHub repo).

I tried commenting out the line in BlynkWidgets.h that includes WidgetGPS.h, but it resulted in the 2nd error.

The 2nd error says 'BLYNK_ALREADY_LOGGED_IN' was not declared in this scope.

I have the .cpp and .h library files in a folder, but I made sure the include statement does not reference the folder (so the include statement is #include "blynk.h"). I also tried adding #include "application.h", but I still get the compile error.

FYI - developing on Windows 7, Particle Dev 1.7.3, Blynk 0.4.0.

I can compile on Particle Dev if I use Blynk version 0.3.10 from here which is the same version being used in the Web IDE (which works).