Problems connecting cores

I have some trouble reading through the forum so forgive me if the anser is “right in front of me”.

The first core:
Hooked up to 1A power supply outlet.
Downloaded Android App.
Core in “blue” mode.
In android app, sets the pass to network.
Core goes to green blink mode…

Ok… trying ones agains,
Mode button changes the green blink to blue.
Using android app
Goes to green blink, nothing more.

Connects to win7 computer, download driver, connecting with putty.
Can read ID.
Setting up network id
Setting up network pass
Goes to green blink and holds it…

Trying 10sec mode button to reset all.
Blinks “white-ish”, holds, blinks white-ish again, holds, blinks green.
Pressing mode for 3 sec, nothing
reboot, goes to green blink
trying app, nothing.
Does not appear in PC

What to do now?

It seems that the reset of the device put it in DFU mode.
I can see DFU info in Windows.
I managed to use zadig to install driver, so now it appears as “Univeral Serial Bus devices” as CORE DFU

What is the next step from here?
Do I need to get my hands on a Linux computer and make an build of the os etc?
Or is there a Windows application and prebuilt image I can test to download?

Hey @mippen,

Sorry you’re having trouble setting up your Core. Just for reference in the future, the first thing I want to do is point you towards our troubleshooting section, so you can get immediate support in the future.

A couple of questions for you. It seems like, early on, you were able to successfully communicate Wi-Fi credentials to your Core, but unable to join the network. What kind of network do you have? WEP, WPA, WPA2? We’ve discovered and are working on a fix for an issue with connecting to WEP encrypted networks. Do you have a u.FL Core, or a Core with a chip antenna?

When you complete a factory reset, the saved network information should be erased, and the Core should revert to the version of firmware that I had when it left the factory. You should not have to reinstall any of the software manually. You will know the Core is in DFU mode if you see RGB LED flashing yellow. For a better understanding of the LED colors and what they mean, visit the link below:

If you complete a factory reset (instructions below), the Core should return to it’s factory original behavior and start flashing blue. Does this occur?

Hold down the MODE button, tap on the RESET button and wait for ten seconds to do a Factory Reset, where the Core is reprogrammed with the software that was installed on the Core in the factory (the Tinker application). The LED should turn white for three seconds and begin flashing quickly; when the LED switches to another color the Core has been reset. This is useful if you encounter bugs with your firmware, or if you just want to get back to Tinker.

Hi Will

I had similar experience with core #2.
The difference was that I moved the core closer to the AP during the “green blink” phase.
After it had established connection I could move it back to the spot I had problem at with full functionality.
Not sure if there is a problem/issue with signal strength during first init on network.

My core #1 that is in DFU mode have been reset’ed a couple of times.
When holding down mode, tapping reset, waiting ~10 sec, I get the white blink.
After a few seconds it starts blinking green (with some red in it).
I can not in this mode hit mode button to change the state.

I have the chip antenna core.
Using WPA2-Personal on my network.

I can not get core #1 to flash blue.

@mippen if you are seeing green blinking with some red in it, it means that you may be seeing an issue with the private key on your Core. Have you followed the instructions located here to generate a new private key?

If you are still having issues, or need help completing this process, please send me a personal email at and I’ll make sure we get the bottom of it.

There is no need for you to put your core into the DFU mode unless you are doing local firmware development.

A green blinking suggests you were able to transfer the WiFi credentials successfully. If it remains green:

  1. The credentials could have been typed in incorrectly => clear the credentials and try again or try the factory reset.
  2. Its not able to connect to the router. Could you provide more details on the router? The Core is know not to connect over 5GHz networks.

I managed to connect my second core to my router.
The difference was that I moved the core closer to the router DURING the router connection.
After it had made its connection I was able to move it back to the original spot and it works great there.

@will I sent you a personal email.

We are having troubles with (re)-connecting one of our Spark Cores. It worked well but for some tests we have removed the core from the Spark Cloud and wanted to re-connect it again. Unfortunately it is not possible any more. After setting the core back to the factory setting we put it in receiving the credentials (flashing blue) and are able to send the credentials over because the led turns into solid blue. Then the core goes into flashing green and stays there… We tried the same procedure with another core and were able to get it up and running without any problem.

Any idea how to solve this problem?
The core-id is: 53ff6a065067544832581287


There’s quite a few discussions on this recently and i’m wondering why.

The frequency is increasing somehow.

One way is to flash the CC3000-patch file and see if it works! Seems to be the working solution based on the recent threads

The general troubleshooting guide i go through with :spark: users is:

  1. Chip antenna or U.fl

  2. Wifi type (Security, router make, SSID/password with funky characters)

  3. Status of LED (flashing green, orange/red etc)

  4. Factory reset followed by sending credentials over Wifi/USB

  5. Patch programming

  6. others

@kennethlimcp thanks for the answer but where can I find the patch and how to proceed?

EDIT: I see the answer is already in your previous answer, sorry i missed that :wink:


Download the .bin file from:

The guide I wrote to install DFU is here:

It’s a little confusing with so many places to get one thing done but yeah…

The github instructions to get DFU running together with driver change is not sufficient for the 1st timers…

Post back if it’s still unclear!

@kennethlimcp, it worked. The core is connected to the Spark Cloud again :-).
Thanks for the support. I found the first paragraph of Spark Core - CC3000 Patch Programmer very usefull.


1 Like

Yeah that’s the main instructions after you have all the tools you need to get started!

Awesome!.. Seems like the patch is doing some magic and those :spark: core escaping from the factory unpatched are reaching their owners :smile:

Shall suggest this when new :spark: owners report a flashing green in future!

@jgoggins, we might need this in troubleshooting? or it’s already there? :smiley:

Hey @kennethlimcp , there is already a section for troubleshooting when it’s flashing green:

Were you thinking something in addition to this is needed?

Looks like you got it covered! :stuck_out_tongue: