Only green led blinking when connected

I tried to connect my core through spark core app, it is not not getting connected as it says time out.
As soon as I connect the core to computer through usb cable for powerr…it keeps on blinking green LED.
when i tried to restore factory or to bring it in listening mode…then also it blinks green led only.
What may be the problem. respond asap.

I had that once… this fixed it for me, i must have put in password wrong. What kind of network are you connecting to?

Right now i m trying with a mobile hotspot created on another android phone (wpa2 security).
We also used the institute wifi network which was not working due to proxy network settings.

While doing factory reset as mentioned when i briefly tap the reset button instead of yellow led the core starts blinking grenn led after 3 sec.

so do you get the blue flash for listening mode?

A factory reset should get you a white blinking light, not a yellow one. Push MODE and keep holding it. Whilst still holding MODE, just press RESET. Keep holding MODE until the LED start to quickly flash white. After white it goes through a whole range of colors. Maybe something went wrong during the factory reset, or you misunderstood some of it (as you expected yellow). Might be worthwhile trying a reset again.

Sorry accidentally i wrote yellow light.
I did not get white light while reset …

The steps i followed :-

  1. When I connected my spark core to usb socket of my computer ,initially it flashed green light for 2 sec
    approx and then led off. (detected using spark core with wifi and arduino compatibility COM49 port)
  2. I want to do factory reset as it was not getting connected earlier through spark app therefore
    i) i pressed the mode button, while pressing it continuously, I tapped the reset button.
    ii) after 3 secs (i am still holding the mode button ) it starts blinking green.

( and the device is detected now in other devices “CORE DFU” mode.)

: Also the blue light is not coming while bringing it in listening mode.

When I Connected my spark core with the help of USB to the computer it initially flashed white for 2-3 seconds and then after it goes flashing green light? What to do? I use fedora18 on my PC