Can't get into Factory Reset and DFU mode


I got 3 cores, 2 of them with u.Fl connector and 1 of them chip antenna. I have setup cores with u.Fl easliy and they worked without issues with my company’s router. But when I try to connect core with chip antenna I got an issure. After setting wi-fi credentials core can’t connect to wi-fi. It blinks green cyan green and so on never breathing cyan.

I decided to make a factory reset or firmware upgrade. But I am unable to get into Factory Reset and DFU mode when I try to hold both button and release RESET button and then the green led started to blink instead of yellow led.

I’ve searched forum but not found a similar issure.
Do you have any suggestions ?

Have you tried the documentation ;)?
Seems that you have mixed up the buttons for the DFU. You need to hold the MODE button and release the RESET button. All that can be found here:

Good luck!

I am sorry I have just written it wrong. I am doing the same thing mentioned in docs.
I edit my first post.

How long are you holding the mode button for after the green flashing? does it change to white after 10-15 seconds?

Does the LED work “normally” normally? ie can you see the 3 individual colors?

No problem, just making sure it wasn’t the wrong combination.
Have you tried all of the steps described here? Personally I’ve noticed that some power supplies can be a problem, in which case they sometimes work, and sometimes they get and endless flashing green loop. Worthwhile trying a different power supply.
A factory reset should (normally) always work. Let’s call in the reinforcement troops on this one: @kennethlimcp @Dave
Installing the CLI, and the CC3000 patch afterwards may also be worthwhile. Even if it’s only for the CLI, which is really useful!
Lets hear what the above-mentioned have to say in this regard. Either way, good luck!

1 Like

Here’s a video of a factory reset, DFU mode is just a matter of releasing the mode button a little earlier:


@Hootie81 I am holding enough I think after a while led is starting to blink green while I holding.
Yes I am able to so blue when core is in Listening Mode. And green cyan when core trys to connect to wi-fi.

@Moors7 Yes I followed every steps but I can’t accomplish them without getting into DFU or Factory Reset mode.

I uploaded a video that I am trying to get into DFU mode. After I release RESET button the green led starts to blink and then cyan loop start over as you can see in the video.

Video link

@Dave I tried it also but it’s not working neither.

Have you tried a different power supply as well, that has often been a problem for me? A computer USB should normally suffice. And make sure you’re keeping contact with the MODE button. They’re rather tiny, so I’ve slipped off of them quite some times. All rather strange…

I didn’t try with another power supply but as I write in the first post I managed to connect my other Spark Core that has u.Fl connector with the same USB hub of my computer. So I don’t think power supply is the problem.

what happens if you hit just the reset by itself? is it the same? maybe the mode button doesn’t work?

It is same. Mode button works well because when I want to delete wi-fi credentials I hold MODE button 10 seconds and it goes to Listening Mode.

Exactly the same symptoms here!!
Also with chip antenna
and can not get into DFU mode

And solved througth cli setup