Problem connecting to WiFi

I just got the spark, but encountered a problem. I use spark command line serial wifi, follow the prompts to fill in the SSID and password are correct. but it keeps flashing green. I have the on board antenna. Have also tried multiply AP & networks. Have reset unit many time with the same results. Any suggestions?

Is your core a white one?

Sounds like it needs a CC3000 patch

Yes this a white one. If so where is the info on the patch & why ship a non functional unit in the first place?

@LarryDog,

The problem was only discovered and dug in users started using in their unique Wifi environments and termed CFOD which you might have read in the forum.

Cores were fully functional and well tested before shipping. We can assure that and some people even hand-built cores before it was shipped! :smiley:

It’s a bug in the TI CC3000 module and causes issues with some wifi environment. Some or most people like me are not affected and I managed to have many cores hooked up to my wifi without issues at all.

I’m sorry that you need to go through a longer than expected process to get the core connected!

You need dfu-util to get going:

Tutorial is here:

The patch file is here:

github.com/spark/cc3000-patch-programmer/blob/master/build/cc3000-patch-programmer.bin

Your newly discovered bug that is unique to only a few Wifi environments, it odd that the patch is 3 months old. I am reluctivity hopeful that this will work out.

@LarryDog,

many has used the patch with great success!

There is a slightly newer patch used in the manufacturing run if you would like to use it but i would recommend the patch mentioned above 1st.

the :spark: team is already testing the latest patch from TI which released just 2-3 days back.

I’m watching this very closely as it has been a wait (from TI side) and will be pushing out this patch ASAP

Hope this helps!

After close examination I have made a mistake. My core is not white but black.
(I am a bone head I was thinking of the relay board) Will this change anything?

@LarryDog,

It means you already have the latest CC3000 patch and if you are still unable to connect to the router, we need to see what’s wrong with the settings.

OK, sounds great. Let me start with I have tried of 4 different networks. This means different router/ap at each network location. In two of the locations I was able to turn of the security requirements (WPA2) no password required. From the serial command line I have only two option & that gives me only three settings (SSID, security, password).

Thanks,

Can you describe the LED status to us?

Was it Blinking Blue to Flashing Green and stops there?

Let’s stay focus on 1 particular network and troubleshoot that 1st?

You only need to send SSID, security type and password which pretty much does what it required to get connected!

1 Like

OK, after entering the SSID (zeus) then 3 for WPA2, then password (ultimeter).
The unit is dark after making the serial connection, after the password is entered there is a short pause.
The unit go blue solid for just a second then start a rapid green flashing that never stops. I hope this helps.

Thanks,

  1. I presume you did the CC3000 patch for your core

  2. You have a chip antenna core of a u.fl with Antenna attached

  3. You are in a good proximity from the router

If the 3 above are fulfilled, can you try WPA for re-setup Wifi again? :smile:

Item 1) I was not able to make the required file for the patch.
I received an error state that on of the files could not be found.
The directory was empty after un zipping the files. If this a must I will have to setup GIT to receive the files.
Item 2) Yes i have an on board antenna, no U.fl connector on spark
item 3) The AP is less than 3 feet from the spark

You can download the patch from here:

github.com/spark/cc3000-patch-programmer/blob/master/build/cc3000-patch-programmer.bin

Click on view raw or right click to download the .bin file

I have a couple items that I would like to add. I have tried three of the four security option 0- unsecured, 2-WPA, 3-WPA2. I have tried changing the AP’s SSID & have tried multiple APs This was done on my current network & was done long before I opened this dialog here. All other WiFi device on this network are working correctly now & before.

Thanks,

@LarryDog,

Let’s not change multiple factors at one time.

  1. Use WPA setting on your router. Make sure it’s on b/g mode and not Auto.

  2. 2.4GHz and not 5.GHz

  3. Perform the CC3000 patch and do a factory reset followed by sending Wifi credentials again :smile:

I can do skype or PM to speed things up and rectify on the spot if that helps

Thanks Kenneth. After the patch upgrade all is great :smiley:

I want to thank you for all of your help & patience with me :+1:

LarryDog

1 Like

my spark core initially when it is powered ON it’s flashing white LED and then after 2-3 flashes it’s starts flashing the Blue LED. and when ever I open my serial communication device and give the SSID it stops flashing and that’s it nothing flashes what to do?

Try doing a factory reset.

I’ve done it but no change till yesterday it was flashing cyan now I’m stuck with blue
when ever the serial communication is opened and i is pressed it’s giving the ID of the core but it’s not responding the SSID.

What to do?