Port Library Request

I really need this Libary, how do I get to use it with my boron?

@DanJow - Not sure what hardware you are using but does this one not do the job? Or what specific hardware are you using? SPI version instead of I2C?

Maybe there another library that is already ported over that would work. You can search libraries here: Particle Search

I tried all of them.

The sh1106 example script is half on and half off the screen.

I’m using boron and i2c.

https://www.adafruit.com/product/4650

https://learn.adafruit.com/adafruit-128x64-oled-featherwing/overview

Can you elaborate a bit on this. What do you mean by all of them?

How about this one:

It indicates it’s compatible with SH1107 which per your link the driver for your OLED Featherwing is SH1107

1 Like

I’ve not tried this one, but it will not load. I’ve refreshed and reopened two or three times.

huh… not sure. I always use VS Code / Workbench and not familiar with the Web IDE. I tried the Web IDE for the first time in several years and like you, when installing that library it hangs. It does install properly in Workbench/VS Code if you want to try that route. In my opinion, it’s well worth the time to learn and get setup in VS Code but I can understand that may not be the answer you wanted to hear.

I.e. Web IDE like you also hangs for me:
image

But VS Code successfully installs it using Ctrl + Shift + P and Particle: Install Library and then entering U8G2.
image