[photon] Stuck in listen mode?

Finally got around to trying out my Photon… not going well so far.

Successfully flashed firmware 0.4.7 (both parts) using dfu-util.

Android app: fails with “Failed to set wifi credentials”. Before doing the firmware upgrade it would go into green blink ‘connecting to wifi’ mode, and never connect. Now it just sits in listen mode. Power off/reset doesn’t get to wifi connection, just listen mode.

Linux USB connection: does not recognize the Photon as a USB serial interface. Any tips on what module I should be using? (I can set a modalias no problem). lsusb shows the device present (2b04:c006) but no description. lsusb -v output here: http://pastebin.com/fcVXAKb0

Linux particle-cli: Installed, connects to the particle over wifi (manually switching networks). Just as per the android app, “particle serial wifi” connects to photon’s AP, photon finds my home wifi (2.4GHz ch 9, WPA2-AES) and I enter credentials successfully (just as per the android app) and sends me back to my own wifi to wait for the cloud connection, but the photon sits in blue-flashing listen mode and doesn’t go to green blink wifi connection state.

Also - tried getting node.js set up on the only windows box I have access to - got stuck with needing .Net framework SDK for VCbuild.exe before I ran out of time last night, so no particle-cli there yet.

Booted a different kernel - photon serial bridge recognised just fine, and particle serial wifi got me connected. For future reference the relevant module is cdc_acm.

Then I had the “bad keys” status - cyan flashing with a magenta/green burst. Fixed that following @mdma’s instructions from [here][1]:

Using particle, first generate a new key:
particle keys new
Then put the device in DFU mode and flash this new key
dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der

Rebooted the photon and it dropped through to breathing cyan - tinker works so i guess I’m online :smile:
[1]: Photon setup flashing cyan with a “quick red burst” (now orange burst) [Solved]


Hi @pwallington,

Wow, sounds like you hit a lot of issues, sorry about that! Glad you got it working! Please do post again if you run into other issues!


Had this same issue with a module today. Had to flash a new key to a module. Probably rare but just thought I would make a note of it.

1 Like