Photon not working properly

I just got the Particle’s Photon like a week ago for a project I’m working on. The problem is that since I got the Photon is giving me problems connecting with the wi-fi network. Eventually I got it to work but it went down again the next day, I can’t get it to listening mode. When I try to troubleshoot it, it wont let me access neither the DFU nor CLI. It doesn’t let me even connect via serial.

Hope I can get help with you guys

Give us some info about your system.
OS, drivers, network, …

How do you try to get into Listening Mode?
How do you try to get into DFU Mode?

I have W10, drivers updated to the last released version and my network is a WI-FI connection with WPA/WPA2 PSK authentication. When I connected to my PC, the PC recognizes it, but it doesn’t turn up in the connected devices.

I try to get into listening mode by pressing the setup button for 3 secs or so, it doesn’t work. It stays showing a green light.
To get to DFU I pressed setup for a while and then pressed reset, but the light never changed to Purple to show it was on DFU mode.

First time I turned on, I could connect to the wi-fi network and run mobile app like the guide said. Like an hour after I tried to connect to it again and it stopped working.

First, make sure the WiFi you want to use your Photon with is 2.4GHz only.
Try a different USB cable and if possible a different USB port too - best 2.0 and not 3.0.
If you can’t enter Listening Mode, you could try to first get into Safe Mode, but no need to wait for magenta breathing, just wait for green blinking and then press and hold SETUP for several seconds (can be more than 3, up to 10 before the credentials get cleared).
To enter Safe or DFU mode, you need to release the RESET button and keep holding SETUP.

DFU mode would be yellow not magenta (or as you said purple).

I tried powering it up today like you said and setup the network at 2.4GHz and tried to get him to listening mode. At first it went blinking cyan, but int the Tinker app didn’t show the Photon as online. The Photon kept blinking cyan, even if when I pressed the MODE button for a long period of time (more than 10 secs). Also, whenever I try holding the MODE button for a long period of time, the LED starts fading until it turns off completely (it stays this way for 10 to 20msecs) and then turn on again and keeps flashing cyan. Now its just dead, and by dead I mean like this:


So even when you unplug it for a while and the replug it, it doesn’t do anything else than this?

In that case, I’d recommend opening a ticket a
You can reference this thread in your ticket

@DrakoBD Have you been able to get your Photon to work? If not have you filed a support ticket? Feel free to DM if theres anything I can do to help.
Kyle @ Particle

Yes, a replacement was sent to me on Wednesday. Since I’m from Dominican Republic, we have to use couriers for a safe online shopping, so I’m still waiting from my courier to receive it and send it to me. As soon as I get Ill update this thread.

1 Like