New Photon only does green flashing or dfu, won't listen any more

Yesterday I plugged a new Photon into a usb port, it went into listening mode, I ran “particle setup” in the CLI, and when it got to the place that it was looking for a wild Photon it never stopped looking. I made sure that I had the latest CLI and node and tried again, and the same thing happened. I then connected to it with putty and used “w” to enter wifi credentials (which is how I’ve usually done it in the past), it said it would connect, but then went to flashing green green only, never connecting.

Now it won’t go into listening mode, even when I hold the reset button for up to a minute. I can put it into dfu mode, where I have done “particle flash --usb tinker” successfully, and also “particle update” successfully. When I reset it it goes back to flashing green, and won’t go into listening mode. This is far from my first Photon and I the others work fine. The router is up and all the other devices I have communicate through it as expected. I’m at a loss here. Any ideas?

tried

particle doctor

yet?

1 Like

I’m assuming you mean the Setup button? Holding the reset button will just take off the power.

Try holding the setup button for ~10s until it blinks blue rapidly, which should erase all credentials. Then try again?

1 Like

OK, now I just feel stupid. I’ve always had trouble keeping the buttons straight, and when I use the right one it goes into listening mode - of course it does. I have it set up and running with the Android app now.

Thanks for straightening me out!

2 Likes