Photon stuck in blue listening mode can't setup

My photon had been fine for a week but then yesterday it started going into green flashing mode all the time. Then I unclaimed and reclaimed it and it worked great for several hours. Started back into green flashing again so I tried unclaim it again but now it just sits in flashing blue setup mode and setup does not work. The app keeps saying “Error please try running setup again after resetting your Photon and putting back in blinking blue listen mode if needed” but resetting does not change anything. Tried doing it with the CLI and that also did not work.

Tried safe mode, didn’t seem to do anything. Thanks for any help.

You should never need to unclaim your device unless you want to pass it on to someone else.
Green flashing has nothing to do with your device being claimed or not.
To judge what might lead to the flashing green, showing your code might help.

When your device is stuck in Listening Mode (blinking blue) that’d be an indication that you had your WiFi credentials wiped off somehow (e.g. by holding SETUP button for 10+ sec or via code WiFi.clearCredentials())

Just provide the WiFi credentials again (either via phone app, or a serial terminal like PuTTY, or CLI).

What exactly did you do?
Did you try

particle serial wifi

What was the response

1 Like

Thanks! The phone app has not been able to do anything with the photon, but particle serial wifi worked and it’s back online.

2 Likes

Hello ScruffR

I had the same problem where my xenon was working fine now it is stuck in listening mode. SO perhaps you are right, I may have cleared the WIFI credentials by holding the setup button for 10+ secs
SO I did a factory reset to start fresh, and it worked it is back to firmware 1.1.0
However, I am unable to connect it to the wifi network using particle serial wifi It is not prompting for a password, so I had to terminate it finally
I am not using two-factor authentication just yet, I do not believe this is a security breach issue on particle cloud.
How do I get this Xenon back without unclaiming and then reclaiming it back?

Xenons don’t feature a WiFi radio. To get them connected to the cloud you need to pair it with a gateway device (Argon or Boron) or plug it into an EtherWing (which would then not require WiFi creds).

Don’t unclaim it, but you - as the current owner - can (re)claim it at any point.

2 Likes

Ok, I am in a maze and I need to get out of this, Here is where I am, Argon is online and connected from this community article if one is pairing Xenon with Argon both need to be in listening mode and only Argon needs to be on the Network. Right Can't pair New Xenon's with Argon from bundle
I tried both ways to pair it but it not working looking for index.js setup ???


How do I pair my Xenon with Argon when Xenon has lost the wifi credential information and Argon remembers it as xenon being part of the network. ?

Never mind I have to remove the device and reclaim it and that did work, It seems there is no other way to add the device when it is stuck in blinking blue but to reclaim it by use particle app and use the QR code scanner