Photon particle connects to cloud briefly and then disconnects

I have had two photons for a few days and then all of a sudden the two photons I have cannot keep connected to the cloud. When starting up, they connect to the cloud for a brief second and then disconnect and go to the solid green light. I have tried claiming them and going through the setup process on multiple WiFi networks(including a phone’s hotspot). I have also tried running the keys doctor and flashing the latest firmware through the CLI. All without avail. This has happened to two units and I am stuck as to where to continue.

Any insight on this matter you may have will be greatly appreciated.

Does this happen when you start the devices in safe mode?

No, in safe mode it appears to connect to the network in safe mode.

Thanks for trying that. This indicates its a problem with your application code. Please flash tinker

particle flash --usb tinker

Which should also resolve the problem. The next step is to then investigate your application code to see what is causing the device to behave this way.

1 Like