[Photon] Particle Android app error: "Setup process couldn't disconnect..."

Not yet. Thank you for the guide. However, I will be able to test it on Monday at the earliest.

I tried connection with Arduino IDE serial monitor. The command “i” works, but the command “w” skips line with “SSID:” without waiting for network name and goes to “Security:” directly, so that it does not connect to wifi after writing the password.

Opps… maybe suggesting the Arduino serial monitor is a bad choice.

Can you use something like Putty?

Yes, I used Putty and writing wifi credentials went well, however the Photon did not connect to wifi. Then I tried all the methods from published guides:

  • I installed photon driver in order to connect the Photon via USB - success.
  • I installed particle-cli and after setting wifi the cli endlessly gained data from. I had to break the script by Ctrl+C - unsuccess.
  • I installed photon-dfu driver - success I refleshed the Photon with 0.4.2 firmware. At second part the final line was error about getting status. - Maybe success.
  • Now the Photon blinks blue right after reboot (reconnection USB cable).
  • However, mobile app fails at first step now with error that it couldn’t get wifi credentials. - unsucess.
  • After refleshing the Photon does not report as USB device more in PC.
  • I tried reset, factory reset, firmware reset with buttons several times with aforementioned procedures at secured wifi (wpa2-psk(aes)) as well as at unsecured wifi without success.

I am afraid that it is a hardware problem. I hope it is just the software one and can be resolved. During weekend I am going to experiment with different wifi network and PC at my weekend house.

Is the Photon blinking green continuously?

After writing wifi credential the Photon blinks cyan (not green) rapidly and continuously with very short yellow blink cca every 1 minute.

Hmm… Havent’ seen this behavior before.

Ping @harrisonhjones

Thanks @kennethlimcp, sounds like it might be a key issue no?

@mrkale can you PM me your device ID? You can follow this tutorial to get it (it works for both Photon and Spark Core)

1 Like

@harrisonhjones you missed out the link above in your post and i have never seen a blinking cyan with YELLOW flashes before.

1 Like

Fixed the tutorial issue and I agree, cyan with yellow is a bit weird. I’ll look into it

Fast flashing cyan with intermittent orange means a problem with the client key. I don’t think flashing blue with intermittent yellow is possible. Could it be the colors are just being confused a little or perhaps appear differently on that unit?

Yes, It could have been orange, not yellow. But it blinks just 2 or 3 times after long cyan blinking period. From support page: Orange flashing: Connection failure, bad handshake

Entirely possible. You can either PM me your device ID and I can check or you can go ahead and perform the keys doctor command.

At keys doctor command openssl fails several times with error “unable to load Private Key” and many subsequent errors 2916, but key files (pem, der) have been created on the PC drive. However, the reseting the Photon and setting up wifi with particle it blinks cyan steadily.

Can you PM me with the exact output from the terminal? Thanks

The terminal output is too long for PM so that I am PMing the dropbox link to listing file to you.

I have upgraded firmware to the 0.4.3 version, tried all troubleshooting procedures, but nothing has helped. Apparantly, one of my two Phtons is a draff, so just 50% production success.

I have what seems to be the same problem but with what has been a working photon. (I was experimenting with UDP buffer size and may have overwritten something - or that might have been a coincidence and nothing to do with the problem.)
Anyway when I reset the photon I get a flashing green followed by fast cyan/very fast red. (Nothing like the red SOS)
Safe mode didn’t get me out of the problem so I tried a factory reset and ran the Particle Android app. I got stuck at the "Setep process couldn’t disconnect …"
I have used dfu-util to reload the firmware (v0.4.4)
I followed the instructions to obtain the photon ID and ran keys doctor and keys send
Still flashing cyan/red and still reporting “Setup process couldn’t disconnect …”

Can you also try flashing the server public key. Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

1 Like

Thanks - I’ve done that. The keys problem is fixed with the new public key.
Looking at the flashing cyan/red thread also points to the likely cause - a power brown out.
The Android app then told me the photon was owned by another user but let me change the owner.
Configure Wi-Fi and Connecting to Wi-Fi happened quickly but it hung on waiting for device connection (with flashing blue and the D7 led on)
Rebooting the router fixed that and I’m now connected successfully again. Thank you @mdma and @bdub (for the keysstuff )
I was quite surprised to find that the photon has retained the name it had before all the trouble arose and despite the apparent change of owner. I guess that the association of name to device ID is at the Particle server end of things.