[SOLVED] Setup process couldn't disconnect from photon WiFi network

Hi, I made a particle community account to ask this question.
Recently I did the second part of this sparkfun experiment: https://learn.sparkfun.com/tutorials/sparkfun-inventors-kit-for-photon-experiment-guide/experiment-8-activity-tracker

It required me to disconnect my photon from Wi-Fi, I did as instructed and the experiment worked, but when I tried to reconnect to WiFi it didn’t work and said my board was offline. It told me to reset the board by disconnecting, but it stayed offline.

I decided to unclaim and reclaim the device because that was the only way to reconnect the wifi I knew. However it got stuck on the second step, I clicked the reset button because that had gotten to claiming wifi set up to work before. It didn’t work this time. Now I constantly get the “Setup process couldn’t disconnect from photon WiFi network” error message.

I tried to reset the mode until it was blinking blue rapidly and trying again. This hasn’t worked. I desperately need help as I’m on a tight schedule to finish every experiment in the link earlier.

A few things to note:

  • I can’t factory reset the board, if I hold mode and reset down it stops at blinking yellow.
  • I’m a complete newbie. I have no idea how to use anything other than the particle app to fix any of this.
  • I’ll probably need an extensive walk through on how to fix this.
  • I have already seen many other posts regarding the same thing, none have done a good job of helping so far because I don’t understand what people are trying to tell me to do!

That’s all, thank you to whoever puts the time in to this to save my life.

SOLVED: I put my device in safe mode and tried to re-claim it. This worked for me!

Hey there, welcome to the community!

From a quick glance it seems as though you’re using system modes which turn of the connection. Resetting the credentials or resetting the device wont make a difference since your code still runs and will turn of the wifi anyhow.

That might be because there is no factory reset on the Photon. Check this link for that. Incidentally, that should also contain the fix, namely Safe Mode. Have a look :smile:

Thanks for responding, I’m having trouble finding what you want me to find, all I see are the different modes. If it was the WiFi reset you were referring to I have already tried to do this. If you could point me in the right direction it would be a big help!


That should disable your code, and allow you to flash new code.

I put my device in Safe Mode, but I can’t flash any code. Could that have something to do with the fact that I unclaimed the device?

Hey Moors7, after going into safe mode and trying to re-claim my device, it worked! I might have been asking for a lot of hand holding, but I’m very grateful for the time you put in to help me solve this.