Photon not working, stuck at magenta solid/blinking

I’ve just received my photon and set it up.

But it doesn’t work: after I configure the wifi it connects, but after that it shifts between blinking and solid magenta. I’ve checked the logs and it’s repeating three messages: online, cc3000-patch-version, and auto-update. I’ve tried reset, factory reset, just waiting for an hour, to no avail.

Any ideas?


When it is blinking magenta, it means that the Photon is undergoing an OTA of the system firmware upgrade. Does it complete successfully and get to breathing cyan?

What logs exactly?

@Moors7, he watched the events published by the firmware upon :cloud: connection that can been seen using Dashboard or events stream

1 Like

Sounds like the cloud thinks your photon is a core, if it is trying cc3000-patch-version.

@AndyW, that’s a system published event and the name is simply cc3000-patch-version as of now for core or photon :wink:

OK, well, so much for the simple ideas.


Hi, thanks all for the answers.

I tried a few hours later and it just worked. Strange… but at least now it works :slight_smile:

Solid magenta means that the device is performing an OTA update and it’s waiting for data to download. If it doesn’t get data within 30 seconds it will restart automatically and retry.