Photon lost XP drivers

I’m connecting my Photon to my XP laptop. I’ve done this many times before without problems. This time though when I plugged it into the USB, it goes “Cannot install this hardware” I pointed it to the same directory I used before, “Particle_Windows_Serial_drivers” which contains P1.inf and photon.inf but it just gives the same error.

Not sure what’s changed. How do I (re)install the Photon drivers? Thanks.

Have you updated your system firmware by any chance?
I had some issues when going from 0.5.x to 0.6.x since the new secondary USB Serial got in the way.
The solution was to remove all drivers from the system (via DevMgr and tick remove from harddrive).

For that to do you need to show non-present devices in DevMgr

After that try reinstalling the most recent drivers

As a matter of fact, yes. I deleted the old drivers, downloaded the new ones and ran the .exe. It wanted a reboot so I did that. After rebooting, I got the “Found new hardware” pop-up for “Photon Serial” and that installed OK.

But then it popped up a Found New Hardware for “Photon Control Interface”. I clicked “Install automatically” and got “Cannot Install this Hardware”. I tried again pointing it directly to the temp directory where the new inf files were saved but it still goes “Cannot Install this Hardware”.

Maybe one of these threads can help
No com port being assigned to my (photon) devices
0.6.0.rc1 - USB Serial - only seeing one but expect two

You could use zadig to install the WinUSB driver for that interface.

Otherwise you can file a support ticket.

If Photon Serial was installed correctly that should be enough.

Control Interface is not currently used by any of the tools and there is no inf file for it, as WinUSB driver should be automatically installed for it with WCID. If you don’t have latest updates installed for WinXP or as far as I remember if you haven’t used WinUSB driver even once, you might have to attach WinUSB to Control Interface manually with Zadig.

A comment from

Only WinUSB on Windows Vista or later requires no user intervention whatsoever. For libusb-win32 or libusbK, or for WinUSB on Windows XP, the WCID driver must have been manually installed at least once (but only once)

1 Like

Well I ran zadig and installed WinUSB and clicked on “Install WCIDDriver”. It said that was successful so I rebooted the PC (just for good measure) and then replugged in the Photon. This time it didn’t complain about any drivers and I can see Photon listed in Device Manager. But when I opened Particle Serial Monitor, I didn’t get any output from the Photon (even though the running program was generating serial data output).

I unplugged the Photon, rebooted the PC, and now it’s going “USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it”. And the Photon is not listed in Device Manager. I tried plugging the Photon into a different PC and got the same message. I’m starting to think there’s something wrong with the Photon. It still pulses cyan and I can flash code to it over wi-fi but the USB seems to be non-responsive.

I there anything else to try at this point? Mystified …