Photon doesn't make it to particle cloud

I tried to put a Photon into Safemode by pushing both buttons and releasing the reset button as immediately after the status LED flashes magenta. Then the whole startup sequence starts, finally ending into flashing green and then cyan. From then on the device continues flashing cyan, interrupted by some red flashes after a while and then continuous flashing cyan again. And this goes on forever.
Then I have put the device into listening mode (blinking blue) and I tried to do a complete new setup (through the particle app). All seemed to work fine initially, but the setup sequence did not complete the last step: Verify Device Ownership, with the status LED breathing green.

Is there anything that I can do to resuscitate this Photon, or is this Photon dead forever?

You probably need to reset the device keys on the device. The short answer is, in DFU mode (blinking yellow):

particle keys server
particle keys doctor

The long answer is:

2 Likes

Thank you rickkas7!
This was very helpful.

I’ve tried the same procedure with a Photon device that showed the same behaviour (flashing cyan, sometimes interrupted by red flashes).
With this one it didn’t work unfortunately.

What I got was:

when running particle keys server:

PS C:> particle keys server
Okay! New keys in place, your device will not restart.

when running particle keys doctor:

PS C:> particle keys doctor xxxxxxxx
New Key Created!
Make sure your device is in DFU mode (blinking yellow), and that your computer is online.: I couldn’t find the file: xxxxxxxx_rsa_new.der

(xxxxxxxx being the Device ID)

Any idea what to do next?