"particle keys" to resolve cyan flashing with red

I’m trying to understand how the particle keys command works.

I have a bunch of devices in the field. Somehow one of them is now unable to connect to the cloud - flashing cyan, with a red flash mixed in.

If read that I need to use “particle keys doctor deviceID” and then “particle keys server”, but I’m worried that somehow that’s going to invalidate the keys on all my other devices.

Is the “particle keys server” command safe?

Yes, it’s safe.
It only affects the device that’s connected via USB in DFU Mode.

BTW, 0.7.0 should rid you of the need to repair keys as the device will keep them up to date or “repair” them when needed.

1 Like

I’m having this problem. My Photon is on v0.6.3. I’ve put it in DFU mode and ran >particle update. Still v0.6.3. Downloaded firmware using build.particle.io and ran >particle flash --usb firmware.bin and still it is v0.6.3.

When I run >particle keys doctor deviceID it … the Photon reboots and I get an error that the Photon isn’t connected.

Can’t get this fast Cyan flashing with an intermittent Red blink to go away. Read all the things. Tried all the things. Hmmm.