Photon blinking cyan with red bursts: Support instructions failed [Solved]

Hi guys, thanks in advance for assistance.

My Photon is continually flashing cyan with with a regular quick red burst. It’s been claimed and was previously connected and working fine but has suddenly stopped connecting.

I’ve completed the 0.5.3 manual firmware update as instructed, which resulted in a restart and return to the blinking cyan with red bursts.

I’ve tried following the key reset instructions, but when I run the below command (pasted from the instructions) I just get the following error message: "Please specify a server key in DER format."
particle keys server cloud_public.der particle keys new photon particle keys load photon.der particle keys send

Back to blue cyan blinking with red bursts.

Can anyone help me…? I’m totally lost - very much a beginner in this stuff!


Like in countless other threads dealing with red burst

I’m going to write it again:
Try this

particle keys server
// see if that worked, otherwise do that too
particle keys doctor <yourDeviceID>

Hi ScruffR, thanks for your help - problem solved. I was struggling after the support instructions didn’t work and the first few solutions in some of those those posts didn’t come through either.

Did you explain anywhere what those commands are actually doing? Just need to learn as much as possible right now!

Thanks again!

I can give you my view of things (since I’ve not gone down that rabbit hole too far)
As I understand it
particle keys doctor bundles several steps of the original step-by-step approach to build and flash the local keys for your device and push that info to the cloud, and
particle keys server will sync any changes that happened on the cloud side back into your device

Why do I drabble? :blush: Here are the docs :wink: