Photon constant white

@mdma new trouble with another photon. I unpacked a photon, went through the particle setup and it was ending in breathing magenta. It was doing that for a long time and it did not show up in the devices list on the web IDE. I read somewhere to flash the latest firmware, so I went into DFU mode (yellow) and flashed the latest 0.4.3 firmware. It ended showing a constant white light, well almost, I think it is somehow stuck in a reboot loop as it flickers a tiny bit.

Any idea? Did I do something wrong? It’s really a bit painful… it’s not the first one.

Was the device claimed? If not, then it won’t show up in the devices list. Breathing magenta means it is connected to the cloud so should appear in the devices list once claimed.

0.4.4 is the latest firmware although 0.4.3 should be fine. The issue is caused by some corrupt memory that is causing system flags to become locked. It’s a bug in WICED that we only discovered after release - the 0.4.3 firmware attempts to patch the bootloader, but can only do that if the device actually starts main firmware.

Please try starting the device in safe mode.

If none of that works, then please create a ticket. Our customer support team will be only glad to help and they are familiar with these issues and can help you resolve it.

ok, no more constant white. I presseed setup longer, then it began flashing blue again and I was able to connect it to wifi. I did particle identify, tried to claim and figure out it is claimed - it was in the list, too. It currently is now breathign magenta, which I understand is safe mode.

The problem is, it does not show up in the active devices. E.g. no blue flashing dot next ot it in th e devices list. I tried setting it as active device, but it will not flash to it.

ID is 3c001f000647343232363230

What does particle list say?

I’ve run particle list and it shows that just one of the other Cores is online. I have the Photon that is breathing cyan next to me, apparently cyan breathing safe mode, it does not seem to be in that list.

Particle identify gives me the id 3c001f000647343232363230 - entering it online to claim that core, gives me a ui popup that states it is already present. So I cannot claim it, but I also cannot see it online, even though it should be in safe mode, connected to the cloud :frowning:

Any other ideas?

What does particle device add 3c001f000647343232363230 say?

Oh well, a few days gone and tried to continue this morning. I cannot get it into the safe boot mode now, it hangs on the green flashing LED now - the network etc is al the same, so if it was able to connect earlier it should still work. I might flashing again with DFU-Util and then contact the tech support for a replacement.

  • particle update
  • particle flash --usb tinker
  • particle serial wifi
  • particle device add 3c001f000647343232363230