Photon can only enter DFU mode with D7 dimly lit, unable to enter other mode


As of the title, when i hold the SETUP and RESET button and let go of RESET
i could not switch to other modes. It stucks at DFU mode.
I connected to my own hotspot , so now it can only connect to that.

Tried entering safe mode, and it happened once. flashed a code but after that cant access to it anymore.

What could be the matter?
i have yet to connect to other sensors on the board other than the one came with it.

PS: i just got the device merely 2 weeks ago. I did have problems flashing Tinker and connecting to the device but i manage after wondering through the forum.

I hope Im not the only one facing this problem.

Warm regards,

In DFU mode, using the CLI, could you try particle update and again with particle flash --usb tinker?

Just recently it became like that.
Usually it runs.

Could you try it from the ‘regular’ Windows command prompt, rather than the Node.js one?

Photon in DFU Mode should not be listed as Universal Serial Bus Device.
In order to use it in DFU Mode you need to install the DFU drivers via zadig as shown here

But as it seems you don’t even have dfu-util installed, so I’d recommend to uninstall CLI and install the full package with this

1 Like

Hi Moors7,

I tried with normal command prompt, i cant access from there.
Only works when i try with node.js command prompt.

Hi ScruffR,

Already tried but no luck in fixing the Photon.

PS: Able to update the firmware. Problem still persist.

troubleshoooting so far, I am still unable to switch to other mode other than Safe mode(hardly but a few times)
and DFU mode only. It wouldnt change to green / listening mode.