Photon stuck in DFU mode after firmware update

HI. I recently purchased the Photon inventors kit from Since my photon was not flashing with the latest firmware update which would allow me to use the Tinker function of the photon I followed the link in the guid to the instructions to update the firmware via Telnet. I downloaded the 2 bin files from and placed into DFU mode (flashing orange/yellow). Everything seemed to work and it did communicate and update, but then nothing. I can’t get it out of DFU mode no matter how long or what combinations I use with the Mode & reset buttons. Not sure what else to do. I’m very new this and any help would be greatly appreciated. I tried to get assistance from Sparkfun, but that didn’t lead to anything.


Have you got the CLI installed? If so, place the photon in DFU mode, and issue particle update, after that, place it in DFU mode once more are issue particle flash --usb tinker. Let us know if that helps.

I tried to use node but this is what I see.

$ npm install -g particle-cli
SyntaxError: Unexpected identifier
at Object.exports.createScript (vm.js:24:10)
at REPLServer.defaultEval (repl.js:225:25)
at bound (domain.js:287:14)
at REPLServer.runBound [as eval] (domain.js:300:12)
at REPLServer. (repl.js:417:12)
at emitOne (events.js:82:20)
at REPLServer.emit (events.js:169:7)
at REPLServer.Interface._onLine (readline.js:210:10)
at REPLServer.Interface._line (readline.js:549:8)
at REPLServer.Interface._ttyWrite (readline.js:826:14)