Photon and Power Shield

Hi, I have a new photon and a power shield. I powered the photon for the first time from the shield and performed initial setup. I then plugged a USB into the photon for serial debugging. All worked fine. Later I tried powering the photon directly from its USB and and the led flashes and flickers a pink-red and the device is not responsive. It however does continue to work correctly when plugged into the shield.

Has connecting the photos USB whilst plugged into the shield damaged the photons regulator?, or perhaps it was faulty to start with.

Thanks, Dean

Could you provide a video of the colors you see?

When you say pink-red, could it could be that the Photon is pulling a firmware update, that should have been part of the initial setup, but got interrupted for some reason.

Thanks. Its definitely not the safe-mode red/purple colour. Not sure how to embed a video so here is a link.

Thanks for your help.

What’s the code you are running on it?
How does the Photon behave in Safe Mode?

The code is a simple DHT22 sampling that I run on a number of photons. It behaves the same if I reflash it with tinker.

In safe mode it behaves as expected, safe mode is recorded on the dashboard.

If I power it from a 3.3v source directly to the 3v3 / gnd pins it works fine, just not via USB.

Does this confirm its a regulator issue ?

Thanks, Dean

For that you might need more checks, like

  • try at least two other USB cables
  • try a different USB power source (wall wart, USB port, computer)
  • try pressing on the USB connector/gently wiggle the cable

The shield adds better DC filtering, the USB connector could have bad contact (either in the solder pads or the contacts to the cable), the battery helps overcome current spikes, …