Power shield v2.1 power issues

Hello guys,

It seems like there is an issue with the shield or with the firmware if it has any, or maybe it does not have the functionality that i was expecting.

So first issue that i saw is if you connect the photon to the headers and put the battery the photon rgb led has a light dim red colour and nothing happens, you remove the battery and connect it back the photon starts to work.

Second issue, i put the usb on the power shield to charge, the led is blue and the battery goes to 100 % then if i leave it like this connected all the time, the red status led gets on and the battery starts to discharge like there is no usb connected, i just leave it like this and the battery still gets lower and lower so that means that somehow the photon gets powered by the battery part and not by the usb part.

The idea was , as long as there is power connected to the board to use that and once power is missing to go to the battery like a small ups. but it seems that it`s not like that .

if i disconnect the power supply, leave it little bit and reconnect it , it starts to charge again and the cycle repeats itself. i did not tried to flat the battery to see if the charging part starts automatically after a certain level or not.

please let me know if this is a bug or if it is normal.

Thanks.

Hi guys,

Any updates ? i’m kind of relying on this board to do the job and if does not work properly i don`t see the purpose of the power shield.

Thanks in advance.

I see similar behaviour, while the first one seems more severe, I wasn’t able to come up with a reproducable missbehaviour - just sporadic, which is hard to pinpoint.

But for the second I’d assume that it’s actually bad for LiPos to be kept fully charged permanently, so you might have to do a long term test if it will cycle the battery - where three days should have been plenty time to test.

As in the other thread mentioned three weekend/bank holiday days are not representative for the Particle response time :wink:
It’s a business with business hours after all.

Continuing the discussion from Power shield v2.1 power issues:

Oh Sorry, i got it now, well for the 1st issue it happens always so i guess it is an issue somewhere and for the second part i get the lipo charge but for example i’m looking on a solar deployment where day time will use solar as much as possible and night battery in case i`m doing a hungry setup, but in this case i’m afraid that the battery will be wasted all the day and when i need it in the night will be empty because it run all the day long. So ideal will be to charge the batt as long as possible and use alternate power and once the alternate power is missing to use the lipo.

I will do a test to see how long it stays like this and if it charges again or not, i did not tried yet on the other terminal but i will do some tests as well so see maybe that part is more different from usb.

Regarding the first issue i could do a small video for proof as honestly i don’t see the point of doing that, maybe it’s a protection for the lipo management circuit and anyway normally once you have the batt in you just need to replace it if you run into problems but still.

In the same time maybe just my point of view, but usually the charging is signalised by red and the complete is blue, here is upside down, no issue here , just an idea. :stuck_out_tongue:

Thanks and i’ll keep the post updated.

I believe you about point 1 - I’ve seen it, but it would be nice if you could provide a video how to trigger it, since I can’t force it to happen.
Very rarely it does it with me, but it does happen.

For this point, it’s not for the circuit but it might be for the durability of the LiPo battery
Room Automation with WeMo and IFTTT

I didn’t notice any odd behavior when setting up a Photon on my power shield with a solar panel and the lipo that came with the shield. I put the Photon in the shield, plugged in lipo, and then plugged into the solar panel.

So far, my Photon has been running on the power shield for 3 days straight without sleeping at all. I have a DHT22 and MPL5113A2 and don’t have anything toggling the power on/off to them. It also does a Particle.publish(...) every minute. I can attest that the battery can run things quite well overnight without charging. However, I think I will need to implement some sort of sleeping before the days get too cloudy and short over winter.

I do have it on a rather large 20V solar panel (with a diode for voltage drop as well as preventing any reverse voltage at night).

I’ll swap it out with a MUCH smaller 6.5W panel I got for like $20 (or less) this weekend.

Here’s a graph of the voltage and state-of-charge stats that get sent with that Particle.publish():

It looks like I’ve mis-configured my data retention history, so I can’t go farther back than 24 hours (oops).

And the environmental data collected from the sensors. I need a better enclosure that can “breathe” for better sensor data.

2 Likes

Hello, nice setup,

My issue was that if i use the Photon battery only and my only connection was usb so i didn`t tried the other input yet.

the issue was :

i put the photon on the power shield;
i connect the lipo and nothing happens, on the photon on the rgb led i have like a little dim red light and that`s it;
i remove the lipo and i put it again, the photon powers up and starts to work.

then i plug the usb, the usb light goes red and the status blue goes on, the lipo gets charged to full then red goes on, and it stays like this and from the status i see that the lipo gets discharged, so it means that the shield does not use the usb power and it uses the lipo power, that was the main issue.

I will soon get a solar panel as well and i will try to use that setup to see how it goes and if it`s different than the usb connection and update the post if any issues found.

Thanks for the info.

so it seems that its like a protection for battery, once i plug the usb or the other part it starts the photon, meaning that it has like a low state that protects the battery and once you connect a power supply goes normally, so i will say that its normal process.