Power Shield - Battery Not Powering Photon


#1

I am using a power shield with a LiPo battery. When The system is powered on via a USB cable it works when the cable is unplugged and the Photon runs off of the battery. When the USB cable is not plugged in and I try to power it on with just the battery, it does not seem to have enough power to turn the system on.

I have 3 LEDs and a hall effect sensor with a few capacitors connected to the photon.


#2

@AlexSneedMiller, what ma/H capacity does your LiPo have? Have you tested the battery itself to make sure it is actually holding the charge?


#3

2000 mAH, it’s the one that came with it. I also tested the batteries that are recommended from the power shield documentation.

It works fine if it starts up with the USB cable and then runs after that off of just the battery. According to the power shield library posting to the dashboard it’s over 4 volts. On the shield the red LED is on and the blue LED is off.


#4

Also, I am using a couple of LEDs and a hall effect sensor. The system seems to be able to boot up when the hall effect sensor is not plugged in. Is it possible that the sensor could be taking up too much current initially and causing the battery voltage to drop too much?


#5

@AlexSneedMiller, can you share your schematic? I need to see how your sensor configured along with the LEDs.


#6

I do not have a schematic for the whole system, but can show here what I have:

Red, green, and blue LEDs on pint 4, 5, and 6 respectively.

This is the hall effect sensor: https://cdn-shop.adafruit.com/datasheets/US5881_rev007.pdf
The ‘out’ pin for a hall effect sensor is connected to pin 2 on the photon.
The hall effect sensor is wired according to the schematic in section 12.1 of the datasheet:
(‘VCC’ is hooked up to the ‘Vin’ on the photon)

Thank you very much for the help!!


#7

@AlexSneedMiller, do you have any current limiting resistors in series with the LEDs? Is anything else connected to the battery shield?


#8

Yes, we do have some current limiting resistors in line with the LEDs.

Just tired with the LED disconnected, but that didn’t seem to help.

When the Vin to the hall effect sensor is unplugged it seems to work. And then we can put the wire back in place after the system boots up.

We tried putting a resistor in line with Vin of the hall effect sensor and that did not work either.

Just the LEDs and the hall effect sensor are plugged in.

The battery voltage is ~4V, and the soc is ~97


#9

@AlexSneedMiller, when you say pins 2, 4, 5 and 6, which functional pins are these?


#10

You should have (at least for the interesting portions for this topic) :wink:
But if you haven’t you could sketch one up with pencil and paper and post the image.

Please try to use the pin labels printed on the board.


#11

Heads up folks, I think I identified an issue in the power shield where the initial rush of current when the battery is first connected may cause the battery control chip to detect a short circuit. This can be worked around by disconnecting and reconnecting either the battery or the Photon after the initial battery connection. We’re also investigating a hardware fix that you could apply to your power shield.


#12

I had seen this behaviour right from the first use of that shield and asked about that, glad to hear that this is now getting attention and I will wait for the fix :+1:


#13

If you are having the issue with the power shield not powering the Photon the first time the battery is inserted you can fix it by adding a 10 nF capacitor between the DPPM pin of the battery monitor chip and ground. This will delay the short-circuit detection logic during battery insertion while maintaining the short-circuit protection at other times.

As mentioned above you can also unplug and replug the battery, or unplug and replug the Photon instead of adding the capacitor.

Here are pictures of adding a 10 nF capacitor to the power shield.

The next revision of the power shield will include this fix.


#14

Kind of late since the hardware fix has been identified, but nonetheless…

What are you referring to as ‘functional pins’?

Pin 2 is the hall effect sensor. Pin 4, 5, and 6 are for the red, green, and blue LEDs. They are pins D2, D4, D5, and D6…

Here’s a quick Fritzing schematic. I couldn’t find the symbol for the hall effect sensor, but there is power, ground, and data out.


#15

@AlexSneedMiller did you figure out your issue with this circuit?

I think it’s most likely due to the issue Julien posted about the power shield. Here is another form of the modification that will be a bit more robust, but requires tiny components and fine soldering skills.

with a 0402 0.01uF (10nF) ceramic capacitor and some decent soldering equipment, you can tack one on right on top of the resistor here. This is the same as DPPM to GND. (that’s a cap soldered on top of the resistor in the picture)

Other than this, your circuit looks fine. The only suggestion I have is that your Hall Effect sensor minimum operating voltage is 3.5V, and it may not be getting enough power because of that if the battery is not fully charged. You could look for a sensor that operates between 3.0V and 5.5V (even though the power shield will only put out about the same voltage on VIN as is on the BATTERY (i.e. 3.0 - 4.2V). When USB is plugged in, VIN can reach up to 5.05V. And the Photon’s max input on VIN is 5.5V.


#16

Ok Mine just does not power up even with the USB connected to the power shield.
the only time the Photon comes on is when I plug the USB directly into the photon
The shield does seem to charge the battery and the voltage is at 4.03V , but I cannot seem to get the photon powered via the power shield.

Please help


#17

Very long overdue post, but yes that did fix the issue.