ParticleSoftSerial Error

I am trying to use the ParticleSoftSerial library, but when running the example code, I obtained several errors.

Anyone know why I am getting these errors?


I guess you are using Desktop IDE and copied the library sources into the project, right?

If so, you need to remove the examples folder and the src/PartileSoftSerial folder from the project path.

Yes, I have copied the library sources in my project and using the Desktop IDE. I have removed the two folders from the project path, but seem to get the same error. Here is my project directory.


When I build this with sample with Web IDE it builds just fine.

But looking at your project tree it looks as if you removed the examples folder but first moved its content out of it.
When I said to remove that folder I meant along with all its content.
In a Desktop IDE project you mustnot have any other .ino file than just the one in src.

This is how your project tree should look like

And as the presence of the .bin file shows, this way it builds as expected.

However, if you don’t intend to modify the library I’d recommend you don’t copy the sources to your project but rather use the + Add to current project option, which only adds a dependency entry to the file.
If in future you’d intended to upgrade to a newer version of the library, you’d just need to edit the verison number of that dependency entry and can build with the desired version without any further ado.

1 Like

Sorry for the confusion, I did remove the contents inside the folder first, but received the same results. Then did some other testing and sent wrong picture. I matched my tree with yours as shown except my .ino is inside the src folder. If it is outside, I get an error that states “ParticleSoftSerial.h: No such file or directory”

Then I went to the web IDE and tried to include the library without any code and received the same error when compiling.

I have used the same method I am using when adding other libraries and have successfully compiled some code such as the neopixel and the DHT libraries.


This builds for me

What system version are you targeting?

Now with your screenshots I can see it’s 0.5.4 - reed Rick’s comment bellow.


Make sure you’re targeting 0.6.0 or later. In the web IDE, click on the devices icon (circle with 4 lines). If you have more than one device, make sure there’s a gold star to the left of the name and it’s a Photon, P1, or Electron. And then click the > and make sure the target system version is 0.6.0 or later.


Thank you, that was the problem.

The version issue was the final problem, the other factors mentioned before would have prevented a successful build too.


I will keep the other factors in mind, thank you for your help ScruffR and rickkas7!

  • Jeffrey
1 Like


This seems to be an encoding issue not confined to that library or the Particle ecosystem.

Since I’m not using Particle Dev but only Web IDE, Workbench or CLI I cannot reproduce that issue.

I tried the same code in web IDE, I’m getting this problem:

Yup, I’ve just seen these too, but they don’t have anything in common with the encoding error.
However, I have to investigate where these missing references come from all out of a sudden - when I last updated the library they weren’t there :confused:

@majed, I have just pushed version 0.0.14 which should solve these missing references.

great! code verified. thank you @ScruffR.

but see what happened at particleDev

Have you imported the new version in Dev?
Check the file for that.